• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Horde/IMP Problem after PHP5 update

U

unixlibre

Guest
Hi,

I'm having a problem with Horde Webmail after updating php5 to 5.2.5. In the httpd-error.log file I'm having:

PHP Fatal error: require_once() [<ahref='function.require'>function.require</a>]: Failed opening required 'Horde/String.php' (include_path='/usr/local/psa/psa-horde:/usr/local/psa/psa-horde/pear:.') in /usr/local/psa/psa-horde/lib/Horde/Browser.php on line 3

Guess I broke one of the php-extensions, but have no idea about which one of them.

I'm running plesk 8.1.1 on FreeBSD 6.1. Any hint will be welcome.

Best regards.
 
My workaround was to append '/usr/local/psa/psa-horde/lib' to the php_admin_value include_path directive in /usr/local/etc/apache2/Includes/zz010.psa_httpd.conf.

I don't know why it worked fine before and broke after the upgrade. Algo ignore if sometime in the future this directive will be overwritten by plesk.

Best regards.
 
Hi,

We have servers running PSA 8.1.1 and PHP 5.2.4 without problems, another server we have to fix it by adjusting the php_admin_value include path.

Did swsoft bring out a hotfix patch for this problem?
 
it not work here, still with the problem. I'm using freebsd. I try the path /usr/local/psa/psa-horde/lib but still the problem... Say that it can't include the file.
 
Back
Top