1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Horde webmail not showing html messages

Discussion in 'Plesk for Linux - 8.x and Older' started by ssmavi, Jan 11, 2005.

  1. ssmavi

    ssmavi Guest

    0
     
    I am using plesk 7.5.1 fedora. I am not able to check html email messages with horde webmail it is directly showing html code in file. Is it possible to use squirrelmail with plesk. If yes then pls tell how can i install squirrelmail on plesk.
     
  2. zboyblue

    zboyblue Guest

    0
     
    I have a question that is similar to this so I will use this same thread. I just noticed that Horde does not display html messages, it displays them as plain text. Is there a way to have it display html messages or is this just a lacking feature?

    Craig
     
  3. blemming

    blemming Guest

    0
     
    Did anyone figure this out? I am having the same problem.
     
  4. jprince

    jprince Guest

    0
     
  5. jgaris

    jgaris Guest

    0
     
    Did that... still doesn't work. Any other ideas?
     
  6. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Did you modify all 3 files, and then restart horde?

    FYI- in the soon to be released 7.5.3 they have updated IMP and Horde to:

    1. [*] IMP webmail version changed to 4.0.3.
    2. [*] Horde version changed to 3.0.4.
     
  7. jgaris

    jgaris Guest

    0
     
    how do you restart horde?
     
  8. jamesyeeoc

    jamesyeeoc Guest

    0
     
    You can do it several ways,

    1. Restart the server box, this is an absolute way.

    2. Use Plesk CP, Server, Services, then click to restart (or stop then start separately) the services (recommend doing the IMAP and Apache both). This method as well as the command line could fail for a number of reasons (hung process, etc).

    3. Command line:
    /etc/init.d/xinetd restart

    I'll usually try the CP and if that fails, I reboot the box.
     
  9. jgaris

    jgaris Guest

    0
     
    I've restarted and nothing seems to have changed. It looks like everything is happening correctly, it's just not rendering the html. See screenshot below.

    You mention 3 files that need to be modified. Besides for mime_drivers.php, what other 2 files need to be modified?

    [​IMG]
     
  10. bartje3

    bartje3 Guest

    0
     
    From Horde/IMP FAQ:

    Before any attachments will appear inline, inline display must be turned on globally in /horde/imp/config/defaults.php3 by setting one or both of the following variables (depending on IMP version) as shown:

    $default->inline_in_parts_list = false;
    $default->text_parts_inline = true;
    After this, for each MIME type you wish to have displayed inline, modify the entry in /horde/imp/config/mime.php3:
    'inline' => true,

    Note that some mime types (like text/html) may have multiple entries in the mime.php3 file. Pick the one(s) that meet your needs.

    Regards,
    Bart
     
  11. jgaris

    jgaris Guest

    0
     
    I don't have that file (defaults.php3)
     
  12. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Depending on the exact version of Horde you have (which depends on the Plesk version), first you need to find the ~/imp/config/ folder, there you will see a number of .php files. Find the file which has the line beginning with '$mime_drivers', the filename may not be 'default.php3', it may be mime_drivers.php or some other name. Not all servers are exactly the same, like depends on other things such as OS version/type.

    Once you have located the file which has the $mime_drivers line, then you can modify it accordingly. I don't currently have a test server for Plesk 7.5.1 so I cannot give you any other specifics.

    For Plesk 7.5.3 - RH9 -

    Config path/filename: /usr/share/psa-horde/imp/config/mime_drivers.php

    Search for $mime_drivers['imp']['html']['inline'] = false;

    and change it to true
     
Loading...