1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

How do I enable SSH Remote Terminal inside Plesk?

Discussion in 'Plesk for Linux - 8.x and Older' started by Sooz, May 2, 2006.

  1. Sooz

    Sooz Guest

    0
     
    Hi
    Does anyone know how to enable the SSH Remote Teminal inside Plesk 8.0?:confused:
     
  2. noname1984

    noname1984 Guest

    0
     
    First of all, when you mouse over to the ssh terminal icon, what message appear under the "Help & Support" section in the navigation pane?

    If it shows "..is not installed" then you have to install by going "Server->Updater-><your plesk version>", then check on "SSHTerm - SSH Terminal java applet" and then click on the "Install" button to install it.

    If it shows "In order to use the terminal client, you should allow shell access for this domain" then you have to allow it by going "<your domain>->Setup", then find "Shell access to server with FTP user's credentials" and then change its value of "Forbidden" to other type of shells.
     
  3. StuartT

    StuartT Guest

    0
     
    Hi,

    I'm getting the same error:
    However, I have set both the client and the domain up to allow any kind of shell access.

    Under 'Clients' --> client name --> 'Accounts' --> 'Permissions' --> under 'Management of access to server over SSH' I checked 'Client can allow access to any type of shell' --> clicked 'ok' to save.

    and then:

    Under 'Domains' --> mydomain.com --> 'Domain Administration' --> 'Domain Administrator Access' --> checked 'Allow domain administrator access' and then under 'Management of access to server over SSH' I ticked 'Domain administrator can allow access to any type of shell' --> clicked 'ok' to save.

    I still am getting this error, can anyone advise?

    Thanks,

    Stu
     
  4. DannyM

    DannyM Guest

    0
     
    you need to do this via the website settings (you'll see an option for SSH with FTP credentials)
     
  5. BobbyJ

    BobbyJ Guest

    0
     
    Confusingly, it's actually labelled "Web Hosting Settings" under the "Web Site" section for the domain. Took me a LONG time to find that ...
     
Loading...