1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

How do I force TLS/SSL for SMTP authenication?

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by Ying HaoM, Apr 14, 2011.

  1. Ying HaoM

    Ying HaoM New Pleskian

    13
    35%
    Joined:
    Apr 14, 2011
    Messages:
    17
    Likes Received:
    0
    Hi,

    I'm finishing up the installation of our Plesk 10.2 Ubuntu 10.04 machine. One of the things I want to do, is disable all unencrypted authentication. I've succeeded for everything except SMTP (Qmail).

    Obviously, I can't close port 25 and force use of port 465, because then mail delivery will break.

    I've tried all sorts of environment variables I could find in /etc/xinitd.d/smtp_psa, but nothing works.

    Postfix has a smtpd_tls_auth_only option, but I can't seem to find it for Qmail, nor where to set it in the plesk-installed version.

    Any help is welcome.
     
  2. Ying HaoM

    Ying HaoM New Pleskian

    13
    35%
    Joined:
    Apr 14, 2011
    Messages:
    17
    Likes Received:
    0
    I found out I could just run /opt/psa/admin/bin/autoinstaller and replace Qmail with Postfix. With postfix, I enabled smtpd_tls_auth_only and it's done.
     
Loading...