1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

How do I forward MX request to external IP?

Discussion in 'Plesk for Linux - 8.x and Older' started by Morphe, Sep 1, 2005.

  1. Morphe

    Morphe Guest

    0
     
    I have a mail server. My hosting server is using plesk. I want to forward my MX Record to my mail server. How do I configure my DNS records with Plesk DNS interface?

    Ilker

    Thank you..
     
  2. sieb@

    sieb@ Guest

    0
     
    Make an A record that points to the IP of the mail server, then have the MX point to that A record.
     
  3. Morphe

    Morphe Guest

    0
     
    Hi again,

    Thank you for answer. My DNS conf. is here;

    Host Record type Value
    yakacikvalf.com.tr. NS ns.yakacikvalf.com.tr.
    mail.yakacikvalf.com.tr. A 217.195.205.114
    ns.yakacikvalf.com.tr. A 217.195.205.114
    yakacikvalf.com.tr. A 217.195.205.114
    webmail.yakacikvalf.com.tr. A 81.213.77.234
    ftp.yakacikvalf.com.tr. CNAME yakacikvalf.com.tr.
    www.yakacikvalf.com.tr. CNAME yakacikvalf.com.tr.
    yakacikvalf.com.tr. MX (10) webmail.yakacivalf.com.tr.
    217.195.205.114 / 24 PTR yakacikvalf.com.tr.

    I can see my mail server's web mail service with webmail.yakacikvalf.com.tr address. It's OK. But mails are failed. This is a error;

    'ozgur.oner@yakacikvalf.com.tr',01.09.2005 14:00
    553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)
     
  4. Whistler

    Whistler Guest

    0
     
    You need to ensure that the recieving server has your domain enabled in its mailserver settings...

    The error is because you're not allowed to relay mail throu that server...
     
  5. EvolutionCrazy

    EvolutionCrazy Basic Pleskian

    23
    90%
    Joined:
    Jun 4, 2005
    Messages:
    65
    Likes Received:
    0
    if you use external mx servers you need also to remove that domain from the local qmail config ;)

    remove the domains you want to use external mx services from these files:

    /var/qmail/control/rcpthosts
    /var/qmail/control/virtualdomains

    ;)
     
  6. jamesyeeoc

    jamesyeeoc Guest

    0
     
    He should also point this to the external IP address.

    I would have done it a slightly different way: more like a backup MX / store and forward for the domain.

    Turn off Mail services for the domain in Plesk.

    Put the domain into
    /var/qmail/control/smtproutes
    (single line: domain.tld:ipaddress:25)
    (tells qmail where to send the mail for the domain)

    Leave the domain.tld in rcpthosts
    (so qmail will still accept mail for the domain)

    Remove the domain.tld in virtualdomains
    (tells qmail it's not a local domain)
     
Loading...