1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

How do I safely upgrade from PHP5.2.12 to 5.3 on my Plesk 9.3

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by MeyIT, Feb 3, 2011.

  1. MeyIT

    MeyIT Guest

    0
     
    Hello,
    I searched the Forums but found no clear answer.

    The goal is to Upgrade my PHP Version (5.2.12) to 5.3 without breaking my running Plesk 9.3. Server.

    Can I easily use the Package Installer (YAST) from Opensuse 11.0 or do i need to build the PHP manually?

    Any experiences would be helpful :)

    Thanks in advance!!
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    You can install PHP 5.3 from repository or build it manually but only for hosting. But do not touch admin's PHP because Plesk will be broken completely.
     
  3. MeyIT

    MeyIT Guest

    0
     
    Thanks Igor. I tried to install it form the OpenSUSE 8.0 repository but it dosen't seem to include the php 5.3 updates.

    Officially OpenSUSE actual versions starts by 11.1 all < Versions are not supported anymore. Though i tried adding the 11.1 repository but no luck either. After adding no 5.3. is found in the Package Management even if i only select the specific repository. Looking in the web (http://download.opensuse.org/repositories/server:/php/openSUSE_11.1/) tells me there is a package. In my opinion any try from a 11.0 version is opt out.

    Any idea of a running 11.0 repository with php 5.3 available?
     
Loading...