1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

How to enable quota

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by 105547111, Feb 23, 2011.

  1. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    I had quota off when I installed, but now want to run it.

    How do you do that? It's centos and supports quota.

    I get this in the CP of a domain I want to restrict:


    Hard quota on disk space*
    Unlimited. Hard disk quota is not supported due to the configuration of the server file system.


    Is there a way to get plesk to do a quota check like when you update or install it? There must be a way.

    My fstab does have usrquota against the drive.


    Thanks!
     
    Last edited: Feb 23, 2011
  2. littlefrog

    littlefrog Regular Pleskian

    25
     
    Joined:
    Jul 30, 2008
    Messages:
    176
    Likes Received:
    0
    This URL should help you

    http://www.tomvernon.co.uk/blog/2009/12/enable-disk-quotas-on-plesk-for-linux/

    You basically have to edit the fstab file and enable it.
    May require a reboot and can take quite some time for it to initialize with plesk once done.

    Seconly each time you update and it runs your websites could be down an extended amount of time as a result while it updates the quota settings.

    Hope this information helps.
     
  3. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    Now I am more confiused.
    I have a usrquota against my /dev/VolGroup00/LogVol00. In the fstab and yes it's been rebooted with that so it should be on.

    When I run the quota check it runs and comes back only complaining there is no group file so it can't add usage to the group file.

    It's got the aquota format file on the / of the VolGroup00/LogVol00 (the is only a single aquota file there, somI am assuming it's only a user file so the complaint is warranted about no group.

    Any ideas or you need more info?

    Thanks
     
    Last edited: Feb 24, 2011
  4. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    I am lost..

    It insists that hard disk space available is not available when I try to limit a domain.

    Yet:

    repquota -a

    Shows me all the users and how much space is used.

    Whats up with plesk.

    I think its a bug, it insists there is no quota provided by the OS - WRONG
     
  5. littlefrog

    littlefrog Regular Pleskian

    25
     
    Joined:
    Jul 30, 2008
    Messages:
    176
    Likes Received:
    0
    First... here is my FSTAB
    The change i did was add the ,userquota to the first line.
    I then rebooted and plesk now recognizes the quotas

    LABEL=/ / ext3 defaults,usrquota 1 1
    LABEL=/backup /backup ext3 defaults 1 2
    LABEL=/boot /boot ext3 defaults 1 2
    tmpfs /dev/shm tmpfs defaults 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    sysfs /sys sysfs defaults 0 0
    proc /proc proc defaults 0 0
    LABEL=SWAP-sda2 swap swap defaults 0 0

    Second
    Did you reboot after making your change?
     
  6. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    Yes its been rebooted several times. Its running but plesk says no.

    /etc/fstab

    /dev/VolGroup00/LogVol00 / ext3 defaults,usrquota 1 1
    /dev/md0 /boot ext3 defaults 1 2
    tmpfs /dev/shm tmpfs defaults 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    sysfs /sys sysfs defaults 0 0
    proc /proc proc defaults 0 0
    /dev/VolGroup00/LogVol01 swap swap defaults 0 0
    /dev/sdc1 /media/c ext4 defaults 0 0


    repquota -a

    *** Report for user quotas on device /dev/mapper/VolGroup00-LogVol00
    Block grace time: 7days; Inode grace time: 7days
    Block limits File limits
    User used soft hard grace used soft hard grace
    ----------------------------------------------------------------------
    root -- 42898108 0 0 243211 0 0
    daemon -- 20 0 0 3 0 0
    lp -- 16 0 0 2 0 0
    news -- 7504 0 0 187 0 0
    uucp -- 168 0 0 1 0 0
    games -- 344 0 0 86 0 0
    apache -- 23460 0 0 2935 0 0
    rpc -- 4 0 0 1 0 0
    webalizer -- 32 0 0 4 0 0
    dovecot -- 8 0 0 1 0 0
    squid -- 16 0 0 2 0 0
    ntp -- 16 0 0 2 0 0
    hsqldb -- 20 0 0 2 0 0
    rpcuser -- 40 0 0 5 0 0
    named -- 96 0 0 12 0 0
    xfs -- 4 0 0 1 0 0
    avahi -- 20 0 0 3 0 0
    mysql -- 394356 0 0 1802 0 0
    psaadm -- 4088 0 0 150 0 0
    popuser -- 19416 0 0 1027 0 0
    mhandlers-user -- 92 0 0 2 0 0
    psaftp -- 4 0 0 1 0 0
    sw-cp-server -- 28 0 0 5 0 0
    postfix -- 960 0 0 91 0 0
    hspc -- 744 0 0 90 0 0
    mailman -- 8 0 0 1 0 0
    drweb -- 64468 0 0 185 0 0
    radvd -- 16 0 0 2 0 0
    ossec -- 48284 0 0 133 0 0
    clamav -- 8 0 0 1 0 0
    asl-web -- 3292 0 0 327 0 0
    tortix -- 196 0 0 17 0 0
    ossecm -- 16 0 0 2 0 0
    ossecr -- 100 0 0 4 0 0
    etc
    etc
     
  7. ToolBox

    ToolBox Basic Pleskian

    23
    57%
    Joined:
    Jul 10, 2005
    Messages:
    36
    Likes Received:
    0
    my linux(centos6 ext4) already has quota system and working enough space.

    but plesk report Synchronization Failed because hard disk quota not supported.

    why?

    parallels support team !!!!!
    please fix this problem.


    OS CentOS6 (Quota system already working under system)
    FileSystem EXT4
    Fstab UUID=bfc1050f-42e8-4b37-acfd-960b800c7727 /var ext4 defaults,usrjquota=aquota.user,jqfmt=vfsv0 1 2
    Plesk 10.4.4
     
  8. MariuszB

    MariuszB Basic Pleskian

    21
    40%
    Joined:
    Jun 24, 2009
    Messages:
    38
    Likes Received:
    0
    I have the same issue. Quota on system working great but Plesk don't see it. I have also CentOS 6 64 bit and Plesk 10.4.4.
     
  9. ToolBox

    ToolBox Basic Pleskian

    23
    57%
    Joined:
    Jul 10, 2005
    Messages:
    36
    Likes Received:
    0
    Why do you ignore this problem?
     
  10. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
  11. ToolBox

    ToolBox Basic Pleskian

    23
    57%
    Joined:
    Jul 10, 2005
    Messages:
    36
    Likes Received:
    0
    ---------------------------------------------------------------
    PRODUCT, VERSION, OPERATING SYSTEM, ARCHITECTURE
    Plesk 10.4.4 MU11 CentOS6 x64

    PROBLEM DESCRIPTION AND STEPS TO REPRODUCE
    1.Clean Install CentOS6.
    2.setup plesk.
    that's all...

    ACTUAL RESULT
    Quota on system working great but Plesk don't see it.

    EXPECTED RESULT
    Plesk don't see Quota.

    ANY ADDITIONAL INFORMATION
    none
    --------------------------------------------------------------
     
  12. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Ok. I have forwarded it to developers. I will keep this thread updated with results of investigation.
     
  13. simonkraml

    simonkraml New Pleskian

    13
    35%
    Joined:
    Dec 14, 2011
    Messages:
    11
    Likes Received:
    0
    quota problem fixed

    hi,
    we have fix the problem by disabling selinux on the server.
    after selinux was disabled the subscriptions can be synced without problems.
    regards
     
  14. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Unable to reproduce. I suppose you really didn't have quota enabled.

    http://www.tomvernon.co.uk/blog/2009/12/enable-disk-quotas-on-plesk-for-linux - there's a good description to switch on quota support.

    I've tried to reproduce a problem on mentioned configuration(cos6 + ext4 + selinux) and had a problem with selinux for enabling quota time. But i've enabled selinux after and created subscription with disk quota after this one without any errors.
     
Loading...