1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

How to get PSA SpamAssassin to delete rather than tag as spam

Discussion in 'Plesk for Linux - 8.x and Older' started by kabarty, May 10, 2005.

  1. kabarty

    kabarty Guest

    0
     
    I have found a solution to the whole 'spamassassin stops working when I choose the delete option instead of tagging as spam'

    It's so simple it's scary...

    Under the client's email configuration for the mailbox, within the What to do with spam mail section, make sure that the 'Mark as spam and store in mailbox' option is CHECKED. Yes, checked.

    Then completely blank the box marked Modify spam mail subject by tag textbox and/or remove the tick from the checkbox.

    Then, if you check the actual spamassassin settings for the individual user in /var/qmail/mailnames/<domain>/<user>/user_prefs you should see that it's rewritten it with 'rewrite_subject 0' correctly

    Hope that helps frustrated spamassassin users!

    This works on 7.5.3 and 7.5.2
     
  2. kabarty

    kabarty Guest

    0
     
    I don't like replying to my own threads, but there's some more information...

    I can't get this 'trick' to work by updating the database and then running mchk -v so it looks like it's a manual job through the interface....
     
  3. kabarty

    kabarty Guest

    0
     
    Ignore all that - all I managed to do there is get it to not tag the subject... (Which is an art in itself it seems)

    *sigh*
     
Loading...