1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

How to restore client backups?

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by vprollc, Mar 2, 2011.

  1. vprollc

    vprollc Guest

    0
     
    Hello,

    I had been using Plesk 9.5.x for quite a while. I recently switched web hosts and the new provider provisioned my server with Plesk 10.1.1. In the previous version of Plesk, if I needed to move data from my production server to my development one I would take a client backup, rsync the backup files from /var/lib/psa/dumps/clients to my development server. On the dev server, I would delete the domain I wanted to restore, go into the client control panel and go to the backup manager and restore the backup.

    With Plesk 10, this doesn't seem to be an option any longer as it forces the customer account to be tied to a domain at the time the account is created. When I tried to restore my domain config, vhost content, mail, and databases, I received an error stating that the vhost was already their and it would not proceed.

    I tried changing the domain that was created when the customer account was created and went back into the backup manager but then their were no client backups listed.

    How are administrators and customers supposed to restore client backups in this new version of Plesk without running into the vhost already exists issue? I remember seeing this when I moved from Plesk 8 to Plesk 9 as I used to backup at the domain level, but doing it at the client level was the workaround in Plesk 9. What needs to be done in Plesk 10?
     
  2. Uber Krusty

    Uber Krusty New Pleskian

    15
    55%
    Joined:
    Mar 5, 2011
    Messages:
    1
    Likes Received:
    0
    I'll be watching closely for an answer... Having the same and many more problems making the transition to Plesk 10.
     
  3. shoggy24

    shoggy24 Regular Pleskian

    25
    57%
    Joined:
    Apr 5, 2007
    Messages:
    198
    Likes Received:
    0
    vprollc, were you able to find a way to restore. i am having this same problem now
     
  4. nucknuck

    nucknuck Basic Pleskian

    21
    23%
    Joined:
    Jan 25, 2011
    Messages:
    66
    Likes Received:
    1
    Ok, i´m not sure if i´m right with my answer...

    I configurated the panel to make a daily update of the server of config and domain data.
    These updates can be found by each customer in the panel.

    panel - website and domains - backup manager

    there i can see laste 7 days as a xml file - just click on it and i have different options for restore.

    (may some panel options will have other names - i have to translate it)
     
  5. Miguel Garcia

    Miguel Garcia Basic Pleskian

    23
    23%
    Joined:
    Feb 25, 2009
    Messages:
    27
    Likes Received:
    0
    Really good question. Same problem here, and I don't know how resolve it.

    We are having a lot of problems to move to Plesk 10, all of them with backups and restore process.
     
  6. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    This was fixed in 10.2.0 I think. I would recommend to upgrade from 10.1.1 to 10.3.1. This may fix your other problems as well.

    Regards
     
  7. Miguel Garcia

    Miguel Garcia Basic Pleskian

    23
    23%
    Joined:
    Feb 25, 2009
    Messages:
    27
    Likes Received:
    0
    Not really. If you don't add a domain, you don't have any service plan, so you can't restore it (level client backup).

    Best regards,

    Miguel
     
  8. brod73

    brod73 New Pleskian

    22
     
    Joined:
    Nov 12, 2010
    Messages:
    14
    Likes Received:
    0
    Same problem here with 10.3.1.
    If you dont have domain created you don't see the backup.
    If you have the domain created, then you can't restore because the domain exists.

    Any notices about this???
     
  9. bradz

    bradz Regular Pleskian

    25
    57%
    Joined:
    Jan 19, 2008
    Messages:
    105
    Likes Received:
    0
    How about plesk 10.4? Is it the key to migration?

    Hi, I am have a real tough time moving to plesk 10 form 9.5 (both on linux).
    Has anyone tried using plesk 10.4 on the new server? I have noticed that it is not listed as stable yet, but some note mentioned added restore features. Are you finding it stable and are you able to restore backups from old plesk versions like 9.5?
    Thanks for any input or help!
    Sincerely,
    Brad
     
  10. Sanderv

    Sanderv Guest

    0
     
    I've migrated all domains of a Plesk 9.5.4 server to a new server running Plesk 10.4.4. It has only been a week, and already found quite some bugs. Also ran in quite some problems/bugs testing the migrations. Unfortunately it doesn't really look like they feel like fixing those bugs any time soon.

    I've done the migration using the pleskbackup and pleskrestore command line utilities.
     
  11. bradz

    bradz Regular Pleskian

    25
    57%
    Joined:
    Jan 19, 2008
    Messages:
    105
    Likes Received:
    0
    Thanks Sanderv, It sounds like I should hold off on 10.4.
    I just was able to get the migration manager to connect and I am trying to move some domains to 10.3.
    Hopefully this will work. It would not connect before because direct root access was tuned off. I should know soon. Brad
     
  12. bradz

    bradz Regular Pleskian

    25
    57%
    Joined:
    Jan 19, 2008
    Messages:
    105
    Likes Received:
    0
    The test did work with the migration manager.
     
Loading...