1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

How to Update PHP?

Discussion in 'Plesk for Windows - 8.x and Older' started by TAiS46, Aug 29, 2006.

  1. TAiS46

    TAiS46 Guest

    0
     
    Hello,

    how can i update php von Plesk?
    I have read an Tutorial on swsoft.com, but there was written, that i newd an PHP 5.x.x installer, an PHP.net don't have an installer!
    What can i do?

    Thanks, an sorry for bad English!
    Greetings Simon
     
  2. EuroMaverick

    EuroMaverick Guest

    0
     
    Ha ! Same thing here.

    I want to update to PHP5 and there is a very nice knowledge base article that explains all the steps: http://kb.swsoft.com/article_149_1048_en.html.

    However (and this is very likely me), the installer mentioned in the article cannot be found on http://www.php.net/downloads.php.

    So all you PHP-experts out there - where is the installation file, please ?

    Kind regards,

    Mav.
     
  3. RiXarD

    RiXarD Guest

    0
     
    You can use the installer of version 5.1.5.

    Version 5.1.6 is a re-release of the 5.1.5 version.

    U can find the installer at: http://php.net/releases.php
     
  4. EuroMaverick

    EuroMaverick Guest

    0
     
    Hello Rixar,

    Thank you for your reply. I found that installer myself in the meanwhile and I followed the procedure described. Although everything looks normal, PHP does not work anymore now.

    Trying to figure out what's going on...

    Regards,

    Mav.
     
  5. RiXarD

    RiXarD Guest

    0
     
    Have you set PHP to run as asapi extension on the domain you are trying to use PHP?

    You can set this at:
    General: Domains > [click on domainname]> Setup > check [v] PHP support (run as ISAPI extension) [v]
     
  6. EuroMaverick

    EuroMaverick Guest

    0
     
    Hello Rixad,

    Very nice suggestion - thanks a lot !

    Indeed, for at least one domain, this was not set. However, now when I surf to the domain, I am asked a user account and password ???

    This is getting weirder every minute !

    Regards,

    Mav.
     
  7. RiXarD

    RiXarD Guest

    0
     
    Have you rebooted the server after the update of PHP? this is necessary.
     
  8. Skeeter

    Skeeter Guest

    0
     
    The password prompt means, that there`s a permissions problem.

    The php package you have unzipped doesn`t have sufficient permissions for the internet users. You should use the Plesk Reconfigurator -> Repair Plesk Installation -> check Plesk files security.

    To make sure that php has been installed successfully, go to Plesk -> server -> Components Management. Php should be detected there.

    If php is not detected, there might be a problem with your php.ini file. You should go to C:\windows\php.ini and make sure the correct paths are set there.
     
  9. jjmancini

    jjmancini Guest

    0
     
    I am getting some problems as well.

    On a couple site, the pages are comming up blank. Not inven a phpifo could be ran. Here is an example:

    vanillahd.com

    And I have the permissions error as well, becuase Ion the following site it prompts me for a usernmae and password.

    frunder.com

    I used the plesk reconfigurator, but it did not fix the problem. ANy other ideas?

    Any help would be great... My sites have been down for about 24 hours now and I am getting desparate.

    THanks!
     
  10. Skeeter

    Skeeter Guest

    0
     
    Hi, Jjmancini

    As I can see, vanillahd is back, I hope now you feel better.
    As for the other websites, I can give you these advices:

    This appears to be a permissions or password problem here.
    So, you can try resetting permissions for this specific domain, you should go to Plesk -> Domains -> check the domains that have the problem, then click the "check permissions" button on top of the list. On the next page be sure to uncheck the "check-only mode" checkbox.

    The other possible reason is the lost password for the anonymous user. To check ths one, you should run the following command line on your server:
    "%plesk_bin%\websrvmng" --update-anon-passowrd --vhost-name=<domain-name>, just like
    http://kb.swsoft.com/article_156_976_en.html

    Finally, the reason of the issue might be the permissions problem for ColdFusion extensions. If the password prompt pops up for all websites that use ColdFusion, you should go to C:\CFusionMX\runtime\lib\wsconfig\ and set run/execute permisions for the psacln group for the whole folder.
    It might be possible, that you should set "write" permissions for his folder, check your website and then get it back to read/execute (CF might need to create some logs).

    I hope, this will help you get your sites up and running. good luck!
     
  11. jjmancini

    jjmancini Guest

    0
     
    First of all I want to thank you very much skeeter!

    Ok, to give an update, the php thing was that I had version 4 and 5.2 running at the same time, I do not know how, but I guess that is what happened.

    As far as the user permissions go, #3 in the KB article referenced earlier was the culprit. It is the anonymous passwords were not synced.

    Thanks again for all your help!
     
Loading...