1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

HOWTO: Fix webmail when you get a prompt

Discussion in 'Plesk for Windows - 8.x and Older' started by AbsolutelyFreeW, Dec 23, 2004.

  1. AbsolutelyFreeW

    AbsolutelyFreeW Guest

    0
     
    Go to webmail.<yourdomain>

    You get a prompt box instead of the horde page. If you want to, you can login with a server or ftp user account and everything works, but you don't want that, you want everyone to be able to see the horde login page. what to do?

    Ok, go to the webmail, and when it prompts you click cancel. You will get either of these 3 error messages

    401.1 wrong credentials
    401.2 Server setting
    401.3 Unauthorized <-- the most likely

    If its 401.1 then you have the wrong password for the internet user. goto computer management and local user and groups. Find the "internet guest account" and change its password to something you know. do not worry, nothing scary will happen in spite of all the warning signs. (but hey you follow this tut at your own risk, no liability taken) write down the name of the internet guest account. ok, go to IIS, find webmail site, right click and choose properties, go to directory cedurity tab, push the authentication and access control, check that you want to be able to access it anonymously, give the account name you wrote down, and the password you set.

    what if its 401.2 ok then IIS don't know you want anonymous users to logon to the site. fo the last part of the above. on auth and access control window in IIS check the anonymous login part. If you need the password and dont know it, do all the abovein part 1

    ok, the most probable cause 401.3 at least what was wrong with our server. In IIS find the webmail site and right click, choose permissions. Check that psacln group has read and execute permissions set, if not set it. Next go to computer management local users and groups. check that the internet guest user is a member of psacln. if not add it to the group. For me it didnt resolve instantly, but I tried a few times and then it got it, internet guest user, set to anonymously retrieve the site in IIS, has permission in the file folder system since its a member of psacln. it now works.
     
  2. mgolicher

    mgolicher Guest

    0
     
    Run the Plesk Reconfigurator via the Start Menu. Then select Repair Plesk installation, make sure all options are checked and select Check. Once you start making modifications to permissions/passwords outside of the control panel features you greatly increase the scope for diagnoses/resolution. If it is a permissions issue this should correct the problem.
     
  3. AbsolutelyFreeW

    AbsolutelyFreeW Guest

    0
     
    another reason why you may get a prompt is the plesk firewall. The horde website uses port 8425. Open it in your firewall. Very confusing, you'd get a 401.1 error if firewall is up.
     
Loading...