• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

HTTP 500 error/blank screens after upgrade to 10.1.1

M

martijn189

Guest
Hi everyone,

Two days ago i upgraded my plesk panel from version 9.5.2 to 10.0.0 using the autoinstaller on a server running openSUSE 10.1. After the upgrade completed succesfully i updated plesk to version 10.1.1 using the build in update service of the panel.

The following day, when i tried to login i got a HTTP 500 error after filling in and submitting the login form (it gets stuck on page https://MYWEBSERVER:8443/login_up.php3), if you do a couple of page refreshes (F5) you sometimes get trough. But as soon as you go to modules>wachtdog or the virusscan settings i get a blank screen in the right part of the panel page.

The webserver seems to run fine, altough i needed to restart a couple of times due to mail not being received. Is there someone that has the same issue, or perhaps someone that can help me track down this issue, because i am not an expert in linux and this kind of troubleshooting.

The last error in the: /var/log/sw-cp-server/error_log was the following:

Code:
2011-01-27 09:25:23: (mod_fastcgi.c.2582) FastCGI-stderr: PHP Fatal error:  Class kavInterface contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (VirusFilter::available) in /usr/local/psa/admin/plib/modules/kav/kavInterface.php on line 59

EDIT
I have solved both issues, if you look at the error it says it has trouble using a function called "kavInterface ", i think this function belongs to Kaspersky virusscanner. I noticed that the plesk update tool listed a possible update for Kaspersky, after trying to install that update.. it failed with a error message.

I decided to uninstall Kaspersky using this guide, then restarted the whole server and the problem was resolved. Afterwards i re-installed the premium antivirus (because my license approves it) and i was all done!!
 
Last edited by a moderator:
Back
Top