1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

HTTP Error 503. The service is unavailable

Discussion in 'Plesk for Windows - 8.x and Older' started by C.yW, Jun 15, 2010.

  1. C.yW

    C.yW Guest

    0
     
    Hi all,
    I'm a freelancer, currently working for a small project involving a migration of a static HTML site to a CMS called Concrete5 for my client. My client is subscribed to a webhosting running in windows with Plesk 8.6.

    To be frank, i have never worked with Plesk before as my previous clients are mostly Cpanel or DirectAdmin users.

    While developing my client's new CMS website, i run into some problem when i start installing Concrete5. It (the CMS site) work ok after install but NOT perfect as some folders, files such as .htaccess needs chmodding for the CMS to work PERFECTLY. i knew that chmodding cannot be performed in FTP for windows+plesk, so i logged in my client's Plesk in Web Directories > Permissions to perform some tweaks.

    An info appears on top which says 'Information: 'You are not allowed to change permissions for this folder.'

    Fine, so i returned to Web Directories where the lists of folders and files are listed and made attempts to change their permissions with IUSR etc one by one. I saved and refreshed the site, but it seems like the permission change does not/fail to take into effect as probably a global setting higher up seems to overrides my settings. In short, I assumed that SEF is impossible to achieve now so i gave up trying.

    I then tried to make the webhost recognise index.php instead of index.html. So I switched to Web Directories > Preference. I pushed index.php above index.htm where the Concrete5 site is index.php, while my client's old static HTML site is index.html. Both files are in the root is because during my client's new CMS site development, his old static HTML site is still there. I plan to delete his old site after the migration of his contents to the CMS is complete and after i have done some tests.

    To my shock, after saving the settings, both websites - CMS and static HTML site does not load at all! The error generated says:

    HTTP Error 503. The service is unavailable

    I logged in to my client's Plesk again and switched all the settings back to the way it was to troubleshoot. It failed. The same error appeared.

    Assuming the CMS conflicting with Plesk, i deleted the CMS including its Mysql database to troubleshoot. Again, the results are the same.

    My client's webhost tech support is not helping either as they dont reply emails not until the 4th week, and keep giving empty promises about the outage.

    The project is currently stalled as i cant get my way around this and my client's crappy webhosting tech support is not helpful & cooperative at all.

    I am reaching stalemate and i need to get this solution quick before my client label me as incompetent.

    I welcome anyone with good suggestions or advice to solve this as i am in dire straits. As for your reference, I have attached 3 files of the current state of the settings leading to this outage.

    Thanks in advance
     

    Attached Files:

Loading...