1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

https but no connection via http

Discussion in 'Plesk for Linux - 8.x and Older' started by bmcole, Aug 25, 2006.

  1. bmcole

    bmcole Guest

    0
     
    I've been searching to figure out what's messed up with this, but haven't found a solution so far. I have a domain, xxxx.com, with a dedicated IP that I've set up on a reloaded machine. I can reach it by https or by ftp. I can ping it. But I can't reach it by http. I get the 'can't establish connection' error in the browser. The domain was moved from another server, but it seems to be resolving correctly to IP xxx.xx.xxx.xx. I've deleted the domain and reset it up several times, even restarting apache service between times. I've checked the DNS settings and the include and conf files on the server and everything seems in order. But I still can't get this domain to resolve correctly.

    These are the DNS settings inside plesk:
    xxx.xx.xxx.xx / 24 PTR xxxx.com.
    ftp.xxxx.com. CNAME xxxx.com.
    lists.xxxx.com. CNAME xxxx.com.
    mail.xxxx.com. A xxx.xx.xxx.xx
    xxxx.com. A xxx.xx.xxx.xx
    xxxx.com. MX (10) mail.xxxx.com.
    xxxx.com. NS ns.xxxx.com.
    xxxx.com. NS ns2.xxxx.com.
    sitebuilder.xxxx.com. A xxx.xx.xxx.xx
    webmail.xxxx.com. A xxx.xx.xxx.xx
    www.xxxx.com. CNAME xxxx.com

    Thanks for any help!
     
  2. Matt.D

    Matt.D Guest

    0
     
    I take it you have solved the problem?

    when I view the url, it shows a page for a hosting company called BizyHost
     
  3. bmcole

    bmcole Guest

    0
     
    No. Still no luck.

    No. It's still not working correctly. Bizyhost is just the default domain for one of the shared IP addresses on that server. Last night I deleted the xxxx.com domain and tried setting it up again as a shared domain on that IP. Everything worked correctly. Then I changed the settings back to the exclusive IP address it should be on and it's back to the same problem. I can't get it to see anything via http. But it's coming up with the correct default page on https.

    Good thing my hair is shorter for the hot summer so I can't get a good grip when trying to pull it out.

    Thanks for any suggestions.
     
  4. jas8522

    jas8522 Basic Pleskian

    24
    23%
    Joined:
    Feb 3, 2005
    Messages:
    80
    Likes Received:
    0
    Location:
    Halifax, Nova Scotia Canada
    Anything in the logs?

    Are you able to see anything in the logs? At least this way we can verify if it's a DNS issue or a config issue.

    Check the particular vhost's access and error log - if it shows up there, then the DNS is good, and at least part of the httpd.include file for the vhost is good.

    If any errors show up in your global apache error_log in /etc/httpd/logs/error_log (red hat) then it's not resolving the vhost - it's only attempting to access via the IP.

    Just something to try to help narrow down the problem!

    Jordan
     
  5. bmcole

    bmcole Guest

    0
     
    Log files for the vhost are empty. SSL logs are processing normally. Global apache error log isn't showing anything in it about a problem in this domain.

    Does that mean it has to be a DNS issue? I'm really stuck if it is. The domain is setup in the same pattern as every other working domain on this server.

    Thanks.
     
  6. bmcole

    bmcole Guest

    0
     
    Update...I think I have it working now. All I did was update the httpd.conf to add a line under the Listen statement that was there for the main address. Added another one for the new IP for this domain. Now it works fine.

    I'm still confused though. I thought the included conf file for the vhost told it to listen on assigned IPs. It evidently is working for the SSL part of the site.

    Thanks for the pointers, friends!
     
  7. jas8522

    jas8522 Basic Pleskian

    24
    23%
    Joined:
    Feb 3, 2005
    Messages:
    80
    Likes Received:
    0
    Location:
    Halifax, Nova Scotia Canada
    Listen in Apache conf

    Hey,

    Ahh, I didn't notice that it was a separate IP! Yes you can also get rid of all 'Listen' commands in the httpd.conf file and just put:

    Listen 80

    That way it listens on all IP's with port 80. The benefit is that if you add more IP's to the box, you won't have to remember to add them to the conf!

    I also should have noticed that the SSL was working, so clearly the DNS must be right....

    Jordan
     
Loading...