1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

I got up this morning and.....

Discussion in 'Plesk for Linux - 8.x and Older' started by Diveanx, Dec 4, 2005.

  1. Diveanx

    Diveanx Guest

    0
     
    I have the server set to send me a couple of the logs to my email address every sunday.

    Well today I received them and I tried getting onto a site to do some maintaince and it wouldnt connect.

    I checked one of my other sites and found none of my sites connected.

    I logged into the control panel and found my Apache was stopped.

    When I tried to restart it I received this message : 0: /usr/local/psa/admin/htdocs/server/restart_services.php:28 psaerror(string "Unable to make action: Unable to manage service by websrvmng: websrvmng: Service httpd failed to start")

    I then rebooted the server just to see if that would make a difference and it didnt.

    Any ideas for a newbie?????
     
  2. ShadowMan@

    ShadowMan@ Guest

    0
     
    Have you added anything to the server, such as mod_security? I found (on a number of servers) last night that if you are running mod_security 1.8.x and downloaded the latest rulesets from gotroot.com that Apache would not start due to 2 of them (rules.conf and signatures.conf) are now only compatible with v1.9 and up. I had to restore the previous day's rulesets and then Apache started right up.
     
  3. Diveanx

    Diveanx Guest

    0
     
    Well I ahve narrowed it down. Not sure yet how or why but this is what happened.

    I installed OC Commerce on a site I have for a customer. Anyway the installation went fine. Anyone that knows anything about OSC knopws that it does not come with a Login for the admin so you either have to install a login file or password protect your directory.

    Anyway. I tried going in through Plesk and password protecting the directory and that didnt work. WI could still get in with out being asked for a password so I decided to put the login file that was recommended to me by a person on the OSC forums.

    Once I installed that this moring is when the problem started. This the message I received when trying to start apache from the server side:

    Starting httpd: Syntax error on line 5 of /var/www/vhosts/goapeonline.com/conf/vhost.conf:
    Invalid command '/usr/share/pear', perhaps mis-spelled or defined by a module not included in the server configuration

    Now I had a guy look at it and he actually got the server working but the Nuke part of the site doesnt work now. I get a black page which leads me to beleive it is not communicating witht he database. I looking in the info file for the site and I get this (which is what I think he did to fix the server so it will work again)

    /var/www/vhosts/goapeonline.com/httpdocs:/tmp:/usr/share/pear
    When it should be this:

    /var/www/vhosts/goapeonline.com/httpdocs:/tmp

    Now I am either waiting for this guy to get back online to show me how to fix this or if anyone here can tell me I would greatly apprciate it
     
  4. Diveanx

    Diveanx Guest

    0
     
    Well it seems I have lost my help and I am on my own at figuring this out.

    Anyway. It seems that I have found out that I need to edit my vhost.conf file.

    I am guessing this is the file that was changed when I installed the other file.

    I ahve no clue what so ever on how to do this. I know how to SSH into my server and I know a few commands but that is it.

    If anyone can help me out with this I would appreicate it.
     
  5. Diveanx

    Diveanx Guest

    0
     
    Okay. I got the file changed but it seems I am now having a communication problem between the Nuke site and the Database.

    Any ideas of how I can check this?
     
  6. Diveanx

    Diveanx Guest

    0
     
    Well after a uneventful day (the site still isnt up) I was wondering something?

    I have looked through the files and I dont seen any of the files that are gone or are missing.

    I was wondering if I make a backup from the backup function can I just delete the domain and remake it and upload the backup?

    This may be the easiest thing to do at this point so the customers site is back up and running
     
Loading...