1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

ifmng: Unable to query parameter default_certificate_id

Discussion in 'Plesk for Linux - 8.x and Older' started by fr-k.de, Oct 8, 2007.

  1. fr-k.de

    fr-k.de Guest

    0
     
    I get this message when I try to enter plesk (8.2.1):

    ERROR: PleskException
    Unable to fetch IP addresses list: ifmng failed: ifmng: Unable to query parameter default_certificate_id

    0: /usr/local/psa/admin/htdocs/server/configure.php3:39

    Can anybody help me to fix this?

    Enviroment: SuSE Linux 10.1

    Thanx
    TOM
     
  2. Ronny

    Ronny Guest

    0
     
    Have the same problem.
     
  3. fr-k.de

    fr-k.de Guest

    0
     
    This is what it shows now!

    ... could be one step ahead?

    ---
    ERROR: PleskFatalException
    Unable to get default language.

    0: /usr/local/psa/admin/plib/common_func.php3:156
    psaerror(string 'Unable to get default language.')
    1: /usr/local/psa/admin/plib/countries.php3:293
    locale_list()
    2: /usr/local/psa/admin/plib/common_func.php3:1604
    locale_exists(string 'de-DE')
    3: /usr/local/psa/admin/plib/class.Session.php:162
    Session->Session()
    4: /usr/local/psa/admin/auto_prepend/auth.php3:157
    ---
    I don't how I fixed the certificate problem, but there is still no solution to get into plesk. Any idea with this psa error message?

    Thanx
    tom
     
  4. fr-k.de

    fr-k.de Guest

    0
     
    Next step..

    After reinstall of psa_local_de..rpm I was able to login!

    Now I get following error:

    ---
    ERROR: PleskFatalException
    Dashboard preset used by user failed: DashboardPreset: unable to select: no such row in the table

    0: /usr/local/psa/admin/plib/user/UserAdmin.php:253
    UserAdmin->getDashboardCustomPreset()
    1: /usr/local/psa/admin/plib/dashboard/DashboardLocation.php:39
    DashboardLocation->accessItem(string 'GET', NULL null)
    2: /usr/local/psa/admin/plib/UIPointer.php:520
    UIPointer->access(string 'GET')
    3: /usr/local/psa/admin/htdocs/plesk.php:19

    ---

    Any idea?

    Thanx
    TOM
     
  5. dirty@

    dirty@ Guest

    0
     
    all looks like incomplete/failed update when plesk binaries are already new but database is from previous version and does not contain records that binaries refer to..
     
  6. anb_t

    anb_t Guest

    0
     
    You should fix Plesk database manually to resolve this problem.
    Get the list of all certificates exist in Plesk:

    mysql> select id from certificates;

    Configure Plesk to use an existent SSL certificate, one of psa.certificates.id:

    mysql> replace into misc values ('default_certificate_id',<ID>);

    ./anb
     
  7. anb_t

    anb_t Guest

    0
     
    Re: This is what it shows now!

    Try this:

    mysql> select * from locales;
    +-------+--------+
    | id | active |
    +-------+--------+
    | de-DE | true |
    | en-US | true |
    | es-ES | true |
    | fr-FR | true |
    | it-IT | true |
    | ja-JP | true |
    | ru-RU | true |
    | zh-CN | true |
    | zh-TW | true |
    +-------+--------+
    9 rows in set (0.00 sec)

    mysql> replace into misc values ('def_locale','en-US');
    Query OK, 2 rows affected (0.01 sec)

    mysql>

    ./anb
     
  8. fr-k.de

    fr-k.de Guest

    0
     
    That's it

    thanx a lot!

    Ciao
    TOM
     
Loading...