1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Installing Comodo InstantSSL certs

Discussion in 'Plesk for Linux - 8.x and Older' started by wavedave, Jan 20, 2007.

  1. wavedave

    wavedave Guest

    0
     
    I'm a noob with Plesk and Comodo so I'm not sure which cert
    should be uploaded into the second box ("CA certificate").

    I received 3 certs from Comodo:

    1.) www_domain_com.crt
    2.) AddTrustExternalCARoot.crt
    3.) UTNAddTrustServerCA.crt

    I uploaded www_domain_com.crt in the first box ("Certificate")
    and I *thought* I was supposed to upload UTNAddTrustServerCA.crt
    into the second box... but then I got this warning:

    "The CA certificate does not sign the certificate"

    So then I tried uploading AddTrustExternalCARoot.crt into
    the second box but still got the warning. I'm on CentOS 4.4.

    I'm hoping someone with more experience can help me through
    the process and possibly shed some light on the warning.

    Thank you all for your valuable time and contributions.

    [edit]

    I think I solved the issue by following these instructions:

    https://support.comodo.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=288&nav=0,1,35

    Basically, *both* UTNAddTrustServerCA.crt AND AddTrustExternalCARoot.crt
    must be copied and pasted into the second box with no blank line
    between them. When I followed that procedure, I didn't get the
    warning message.
     
  2. faris

    faris Guest

    0
     
    That's correct. You just paste the text from both, one after the other, with no blank line inbetween.

    Faris.
     
  3. wavedave

    wavedave Guest

    0
     
    Thanks Faris :)
     
  4. jrlo2

    jrlo2 Guest

    0
     
    I had the same problem recently on Plesk v8.1; After contacting Comodo's support department, they seemed to know all about the situation.

    They actually recommended appending and uploading FOUR certificates, not just the three originally provided. I've written more about the problem and my experiences here.

    After following the directions involving the four certificates appended together, the message went away in Plesk, and the certificate worked fine for that website.

    Hope this helps.
     
Loading...