1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Issue IP of Mailer sending E-Mails

Discussion in 'Plesk Onyx for Linux' started by tft7000, Oct 28, 2016.

  1. tft7000

    tft7000 New Pleskian

    0
    70%
    Joined:
    Oct 27, 2016
    Messages:
    5
    Likes Received:
    0
    Location:
    Switzerland
    Hi

    I have a server setup with Plesk Onyx. The server has two ipv4 and two ipv6 addresses.

    In Plesk Panel, Tools & Settings, Serverwide E-Mail Settings I said that the mailer should send E-Mails over a specified IP.
    I specified a special IPv4 (not the domain one) and i said 'none' (keine) for IPv6.

    I realized (because of a gmail complain), that Plesk is sending mails also from IPv6. It is taking the IPv6 from the domain.
    However, I expect, that the mailer is not sending mails over IPv6, if I specify that it should not use an IPv6 address..

    Also in /etc/postfix/main.cf I see the line: smtp_bind_address = <special_ipv4>, but nothing that would prohibit sending mails via ipv6.

    - So either this is a bug in the system: setting ip to none is not working

    - or this is a missunderstanding (eg translation problem for the german language pack): it is not allowed to choose 'none' for ip. In this case at least an error message should popup: eg 'you have ipv6 addresses installed, but did not choose an ipv6 address for the smtp service.'

    - or this is a specification problem: none means actually all
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Make sure that file /etc/postfix/main.cf has record like

    inet_protocols = ipv4

    after that restart Postfix.
     
    tft7000 likes this.
Loading...