1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

IPs changed now DNS problems

Discussion in 'Plesk for Linux - 8.x and Older' started by iDevGames@gmail, Dec 4, 2007.

  1. iDevGames@gmail

    iDevGames@gmail Guest

    0
     
    Hello,

    I need help with my Plesk machine running CentOS.

    My host recently changed my VPS's IPs addresses. Since then (about 4 days) I've been having issues. Here were the steps and config:

    1.) Went to my registrar and changed IPs of my domain name servers ns1.devserve.com to x.x.x.107 and ns2.devserve.com to x.x.x.108

    2.) I have four IPs all set to shared. (Non-exclusive)

    x.x.x.107 has my domain www.devserve.com
    x.x.x.108 has nothing on it
    x.x.x.109 has nothing on it
    x.x.x.110 has idevgames.com and idevapps.com (and some sites not being used)
    These two sites I listed are setup for physical hosting in Plesk.

    3.) DevServe's DNS setting:
    x.x.x.107 / 24 PTR devserve.com.
    devserve.com. NS ns1.devserve.com.
    devserve.com. NS ns2.devserve.com.
    devserve.com. A x.x.x.107
    devserve.com. MX (10) mail.devserve.com.
    devserve.com. TXT "v=spf1 a mx ptr"
    ftp.devserve.com. CNAME devserve.com.
    mail.devserve.com. A x.x.x.107
    webmail.devserve.com. A x.x.x.107
    www.devserve.com. CNAME devserve.com.

    4) iDevGames.com's DNS setting:
    x.x.x.107 / 24 PTR idevgames.com.
    ftp.idevgames.com. CNAME idevgames.com.
    idevgames.com. NS ns1.devserve.com.
    idevgames.com. NS ns2.devserve.com.
    idevgames.com. A x.x.x.107
    idevgames.com. MX (10) mail.idevgames.com.
    idevgames.com. TXT v=spf1 a mx mx:mail.idevgames.com ip4:x.x.x.107 -all
    mail.idevgames.com. A x.x.x.107
    webmail.idevgames.com. A x.x.x.107
    www.idevgames.com. CNAME idevgames.com.

    5) iDevApps DNS setting:
    x.x.x.110 / 24 PTR idevapps.com.
    ftp.idevapps.com. CNAME idevapps.com.
    idevapps.com. NS ns1.devserve.com.
    idevapps.com. NS ns2.devserve.com.
    idevapps.com. A x.x.x.110
    idevapps.com. MX (10) mail.idevapps.com.
    idevapps.com. TXT v=spf1 a mx mx:mail.idevapps.com ip4:204.157.1.251 -all
    mail.idevapps.com. A x.x.x.110
    webmail.idevapps.com. A x.x.x.110
    www.idevapps.com. CNAME idevapps.com.

    (I realize that the SPF setting is wrong)

    6) iDevGames DNS settings WERE set to x.x.x.110, but visiting the site would cause people to be redirected to iDevApps. So the last tech changed the IPs to x.x.x.107. But Plesk still says physical hosting at x.x.x.110. Not sure why the tech changed iDevApps to x.x.x.107 and left iDevGames on x.x.x.110. I want all my sites except for devserve.com to share the IP x.x.x.110. It's my understanding that IPs can hold as many as 255 sites.

    7) This morning, I was able to view iDevApps, but iDevGames displayed a default Plesk server page for me. My host said both sites were working. They recommended I empty browser cache. I did. I also tried to access the sites from different machines and locations. However iDevGames continued not to load and iDevApps loaded. I thought it odd so I asked different visitors. With the above settings, 1/2 the people could see iDevGames, and 1/2 got a default Plesk page. Even after emptying cache.

    8) This afternoon, I got frustrated and tried different settings in Plesk. Rebooted, restarted Apache, etc etc.. Nothing worked so I set it all back to what I have printed above. Now iDevApps also displays default Plesk message. Ahhh!!!


    Everything was running perfect before the IP migration mess. Now I'm all confused about what the above settings should be.

    My hosts last message was:
    "I would assume that it is a DNS cache issue, due to the way the virtualhosts work on a Plesk server. If the problem has not corrected itself after 24 hours please let us know."

    I have this bad feeling that so many techs from my host fiddled with my VPS and Plesk that something deep is broken... something that the Plesk control panel isn't displaying... but if I SSH in and knew what I was doing, could discover. lol

    Any help is appreciated.

    Thanks,

    Carlos
     
Loading...