1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Linux Qmail - slow response

Discussion in 'Plesk for Linux - 8.x and Older' started by rafcarter, Oct 29, 2005.

  1. rafcarter

    rafcarter Guest

    0
     
    Plesk 7.5.3 on Linux fedora core2
    2.4 ghz Celeron 256 Mb ram hosting 3 domain atm.
    psa-qmail 1.03-fc2.build75050506.13
    psa-qmail-rblsmtpd 0.70-fc2.build75050506.13
    psa-proftpd 1.2.10-fc2.build75050506.13
    psa-logrotate 3.7-fc2.build75050506.13
    psa-spamassassin 7.5.3-fc2.build75050506.13

    Using Outlook send/receive with POP/SMTP I'm getting very slow response for sending emails. I receive emails very fast but when sending emails, the email sits in outbox for 35 seconds and then gets sent. Has anyone had this problem ?

    I was using FreeBSD before and VDeck and emails were flying.

    When I test the connection, in everything completes but the "send test email message". It comes up as The specified server was found, but there was no response from the server. Please verify that the port and SSL information is correct. To access these settings close this dialog, then click More Settings and click on the advanced tab.

    This is happening with all the domain acounts that I'm using for each domain. I tried the following options in Outlook.

    My outgoing server (SMTP) requires authentication...checked

    Use same settings as my incomming mail server...checked

    I also tried checking off log on using and put username and password again.

    Also I tried just checking Log on to incomming mail server before sending mail.

    All these options produce same result.

    In plesk its set for Relaying - authorization is required and SMTP is checked. Are these settings correct ?

    Anyone know what I can try doing in Plesk to make email send faster ?
     
  2. poke

    poke Guest

    0
     
    turn off the reverse dns lookup in your smtp_psa and smtps_psa

    -Rt0
     
  3. rafcarter

    rafcarter Guest

    0
     
    Thanks, worked great.
     
  4. poke

    poke Guest

    0
     
    no problem :)
     
  5. resellertr

    resellertr Regular Pleskian

    25
    57%
    Joined:
    Jul 14, 2004
    Messages:
    133
    Likes Received:
    0
    How can I disable on freebsd?
     
  6. jackjoe

    jackjoe Guest

    0
     
    what does "reverse DNS lookup" on qmail smtp do?
     
  7. ShadowMan@

    ShadowMan@ Guest

    0
     
    Some SMTP hosts do a reverse Domain Name Service (DNS) lookup for security reasons when an SMTP connection is established. If this reverse lookup fails to resolve properly, they will possibly drop the connection. By default Qmail does not drop a connection on rDNS lookup failure.

    Basically it does a reverse lookup to try and verify that the IP address points back to the valid domain which supposedly sent the message.

    Many ISPs don't have their rDNS setup properly for each individual client, so since the timeout on the lookup defaults to 30 seconds, it causes a 30 second delay in sending each message from a client workstation.

    Adding the -Rt0 option to the smtp_psa file eliminates this delay time by telling the smtp to not do reverse lookups.
     
  8. DiScDuCe

    DiScDuCe Guest

    0
     
    Some might say this is a bandaid to a larger issue. It seems to me that there are other mailservers (not qmail) out there that can successfully execute are reverse DNS lookup and still connect to Outlook mail clients in a timely manner.

    I too had the same issue and was forced to configure the -Rt0 "fix" but I feel that I may have been robbed of some security in the mean time.
     
  9. PedstersPlanet

    PedstersPlanet Guest

    0
     
    Where do I put this -Rt0, before the last } (brace)?
     
  10. DiScDuCe

    DiScDuCe Guest

    0
     
    Rt0 is the first thing in the server_args.... like this:

    server_args = -Rt0 /usr/sbin/rblsmtpd

    make sure you make the same change to your smtps_psa file as well for your SSL based connections.
     
  11. PedstersPlanet

    PedstersPlanet Guest

    0
     
    Thanks.. I shouldve known that lol
    Now it's fast..... Cheers
     
Loading...