1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Mac Client cannot connect via FTP

Discussion in 'Plesk for Windows - 8.x and Older' started by promod, Oct 27, 2008.

  1. promod

    promod Guest

    0
     
    I have a client who is running OS 10.4x that cannot connect to his site via FTP. They've tried Fetch and Transmit. The only way he can cannot is to turn the client firewall off. He can connect to other servers using both applications without turning off the firewall on his computer.

    This is a new installation of 8.3 Windows and the first Mac user we have encountered.

    Any suggestions?

    Server > FTP Settings displays the following.

    Info: Warning: due to active Windows Firewall and Windows Application Layer Gateway Service (ALGS) not allowing to use a custom passive FTP ports range, it is recommended to switch ALGS off. If ALGS service is switched on, passive FTP ports range will be set to default 5001-65535, ignoring any custom values. Refer to Microsoft Windows help files for the information on how to switch ALGS off.

    Thank you in advance for any ideas!
     
  2. Bender

    Bender Guest

    0
     
    Hi,

    You need to configure passive ftp port range for the ftp server and add appropriate port range to your firewall to allow connections.

    Plesk can configure these automatically in the latests versions (plesk > server > ftp settings)
    Then Stop Windows Application Layer Gateway Service(in command line):

    sc stop alg

    and switch start up mode for the service to Disabled.
     
  3. MohammedA

    MohammedA Guest

    0
     
    Hi Bender

    How can you configure passive ftp port range for the ftp server? I use Windows Server 2008 with Plesk 9.

    In Plesk 9, FTP Settings, I have left the dafult ports 1025-5000 and also ALG service is turned off (through the recommendation that is visible at the top of the page.)

    But when I try to ftp connect to the server in passive mode, it fails to connect. then tries to connect in a port range 5001-65535 that means any custom value is ignored!

    Thank you in advance for any ideas!
    Hamed
     
  4. MohammedA

    MohammedA Guest

    0
     
Loading...