1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Mail not functioning properly after IP address move.

Discussion in 'Plesk for Linux - 8.x and Older' started by seanstephens, Nov 25, 2006.

  1. seanstephens

    seanstephens Guest

    0
     
    Greetings All.

    Here is the background info. We took 2 plesk 8 machines off of our existing network and moved them to another data center. In doing this we had (obviously) to change the ip addresses assocaited with the machines.

    Now we were able to get the websites up and running fairly quickly however now it seems like email is not working correctly. If I telnet into the machine locally (telnet localhost 25) then I get a 220 code right away (Service ready code). Now if I try to telnet into the other machine it takes about a minute to get the 220 code, and sometimes it times out.

    Now this doesnt happen on our other network and I'm going to assume it has something to do with the IP move. We've disabled the firewalls on the machines etc, so its not that.


    Anybody got any ideas.
     
  2. seanstephens

    seanstephens Guest

    0
     
    hmmm,

    I just read somewhere that an SMTP connection does a reverse DNS lookup before it allows the connection (or something to that effect). Anyways,is there a way I can disable it.

    Thanks again.
     
  3. seanstephens

    seanstephens Guest

    0
     
    BUMP!

    Anybody Got Any Ideas?

    Thanks.
     
  4. VIB-host

    VIB-host Guest

    0
     
    BUMP

    I have the exact same problem, after getting new IP-address do to a new backbone.

    I've contacted the plesk support, but they don't care :( Just another reason to consider changing the CP from PLesk to ex.hspare
     
  5. blank_page

    blank_page Regular Pleskian

    24
    53%
    Joined:
    Dec 17, 2006
    Messages:
    229
    Likes Received:
    0
    Hello,

    There are few things that can be checked.

    1) dns servers from resolv.conf should answer fast.(this is the most common)
    2) -Rt0 switch in etc/xinet.d/smtp_psa
    3) the hostname is set up properly:
    hostname -f should returna a good value.
    4) If al of these do not have effect I would force reinstall qmail .
     
  6. KudosDesigns

    KudosDesigns Guest

    0
     
    The -Rt0 thing is something we always have to configure to stop mail sending being extremely slow.

    I'm not sure this is your problem, but if you have changed IP make sure you have told your ISP or whoever handles your IP addresses to setup reverse DNS on your new IPs. You'll have massive problems sending mail if you haven't got:

    host -> IP (A name record)
    IP -> host (rDNS)
     
  7. VIB-host

    VIB-host Guest

    0
     
    The right locations on FreeBSD as I use:

    1) dns servers from resolv.conf should answer fast.(this is the most common) (what is considered as fsat?)
    2) -Rt0 switch in etc/inetd.conf (Done, but not the right way to do things)
    3) the hostname is set up properly:
    hostname -f should returna a good value.(FreeBSD - use hostname, and working percetly)
    4) If al of these do not have effect I would force reinstall qmail . (FreeBSD - Not posibel)
     
Loading...