1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Mail problems from current domain

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by zephieg, Jun 21, 2010.

  1. zephieg

    zephieg Guest

    0
     
    Hi,

    We have setup a new domain in the panel (9.2.2) and not selected any of the Mail or DNS tickboxes. As a result we have only one entry in the DNS settings on Plesk, which is "ns.domain.co.uk".

    We have registered the domain name itself somewhere else, and pointed the A record to the IP address we set the above domain up on, so you can correctly browse to the website.

    When sending mail from scripts on the site, if the domain of the recipient is a name other than the domain of the site, the mail is sent, however, if you send mail to a user of the domain, you get the below error in the maillog.

    The problem is that the mail is being dealt with seperately, by other servers (as per the MX records), but I think the "plesk virutal" relay is expecting to find some details about how to send this mail locally.

    Is there a solution to this?

    Code:
    The error in the mail log when sending mail to the local domain is:
    
    Jun 21 14:34:02 serverXX-XX-XX-XXX postfix/pipe[12207]: DBDE4FA0DC: to=<sales@<domain>.co.uk>, relay=plesk_virtual, delay=403234, delays=403234/0.1/0/0.02, dsn=4.3.5, status=deferred (Unable to select desired mailbox )
    
     
Loading...