1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  1. Sidewinder

    Sidewinder Guest

    0
     
    my outgoing mail isnt working...i can receive mail no problem...but when i send it the mail gets piled up as 'bad mail' and does not send...when i run the diagnostic tool everything passes...but there are a few things that i dont know if are configured right...have a look and see if anything dosnt seem right to you...

     
  2. Sidewinder

    Sidewinder Guest

    0
     
    being that im not the only server admin of this computer...i didnt install it nor configure it....but is it bacause its enterprise edition and i dont have a license for it?
     
  3. cviviani

    cviviani Guest

    0
     
    your dns entry seems wrong

    NS lookup for Hostname: ORGANIZA-CBM4BE.extreme-hq.com
    IP : 255.255.255.255

    NS lookup for ip: IP : 205.209.177.120
    Hostname: extreme-hq.com

    the hostname ( ORGANIZA-CBM4BE.extreme-hq.com ) should be dissolved to the IP 205.209.177.120 . I receive for the host 255.255.255.255 thus that naturally never runs
     
  4. Sidewinder

    Sidewinder Guest

    0
     
    how do i change it? :confused:
     
  5. cviviani

    cviviani Guest

    0
     
    correct the entry for ORGANIZA-CBM4BE.extreme-hq.com in dns section of plesk (has straight seen that everything on one plesk servers runs)

    under dns zone extreme-hq.com insert or edit

    ORGANIZA-CBM4BE a 205.209.177.120
    in plesk you see
    ORGANIZA-CBM4BE.extreme-hq.com a 205.209.177.120

    you can examine also with the notepad the file
    C:\Program Files\SWsoft\Plesk\dns\var\extreme-hq.com
    there then an entry should be looks in such a way

    $TTL 86400

    @ IN SOA ns.extreme-hq.com. domainadmin.extreme-hq.com. (
    1094884518 ; Serial
    10800 ; Refresh
    3600 ; Retry
    604800 ; Expire
    86400) ; Minimum

    extreme-hq.com. IN NS ns.extreme-hq.com.
    ORGANIZA-CBM4BE.extreme-hq.com. IN A 205.209.177.120
    ns.extreme-hq.com. IN A 205.209.177.120
    ns1.extreme-hq.com. IN A 205.209.177.120
    ns2.extreme-hq.com. IN A 205.209.177.120
    extreme-hq.com. IN A 205.209.177.120
    mssql.extreme-hq.com. IN A 205.209.177.120
    mail.extreme-hq.com. IN A 205.209.177.120
    webmail.extreme-hq.com. IN A 205.209.177.120
    ftp.extreme-hq.com. IN CNAME extreme-hq.com.
    www.extreme-hq.com. IN CNAME extreme-hq.com.
    lists.extreme-hq.com. IN CNAME extreme-hq.com.
    extreme-hq.com. IN MX 10 mail.extreme-hq.com.

    when you use microsoft dns it is under windows\system32\dns or use windows dns manager.

    a value(or blank) must be already registered otherwise it would answer not with 255.255.255.255
    do not forget to restart dns
     
  6. Sidewinder

    Sidewinder Guest

    0
     
    woops...no need for this post yet...read it wrong
     
  7. cbtrussell

    cbtrussell Guest

    0
     
    I admittedly skimmed the replies regarding DNS, but note that if you have 7.0.2 or below and enable the Plesk firewall, the DNS queries don't work - and outgoing mail stops. Just FYI from our experience.

    Brandon
     
  8. Sidewinder

    Sidewinder Guest

    0
     
    ok, i believe ive have done what you guys said, this is what the dns manager looks like:
    http://www.extreme-hq.com/other/dns/dnsmanager.JPG

    and as for the firewall it was shut off:
    http://www.extreme-hq.com/other/dns/firewall.JPG

    correct?
    and my outgoing mail still dosnt work
    __________
    i was looking through the logs and the SMTP Debug log had this...dosnt mean anything to me...

    Log Analyser:

    8[1] Communications Error. Socket Connection

    Explanation: MailEnable was able to determine an MX record for the remote server but was unable to connect to it. This means that the remote host is not contactable or is offline.
    -----------
    10[1] Could not resolve MS list for domain

    Explanation :MailEnable could not determine a list of Mail Servers to send the message to.
    -----------
    12[1] Outbount. could not send the command to the server (error 10038)
    Explanation: (Socket operation on non-socket). This error occurs when MailEnable is sending mail messages to a remote server and the connection was terminated by the remote server (usually the result of an earlier 10060 error whereby the server is no longer in communication with the remote client).

    How do i fix these? :confused:
     
  9. cviviani

    cviviani Guest

    0
     
    it can be that you with invalid mailadresse sends (SMTP:admin@localhost). can you send from an official mail address (mail@mydomain.com - where a post office account on your server exists). the receiver can regard you as Spam transmitter.
     
  10. AbsolutelyFreeW

    AbsolutelyFreeW Guest

    0
     
    I have a similar problem for The statistics scheduler, it sends from a bad mail address and ends up as bad mail. Does anyone know where to change that address? I have searched through the whole psa database without finding it...
     
  11. jtheisen

    jtheisen Guest

    0
     
    Fixed kinda a tut

    admin@localhost needs to be changed in mail enable and at the computer level, you will need desktop access to acomplish this.

    My suggestion
    1st get the latest version of mailenable, free paid what ever, but dont rely on the evaluation version of pro or enterprise. install fresh or overtop of existing, i had v 1.73 with my default install of plesk only to find 1.9 was out that fixed a buch of stuff.

    2nd your computer name (right click my computer) put it in a work group, and then name it something like webone or whatever.
    click change and add your dns suffix (your fqdn) yourdomain.com - apply and reboot

    In your DNS settings (registrar or where ever you control your dns from) add "webone.yourdomain.com" and point it to the IP address of the server. Make sure you request a PTR for your main domain and make sure it points back to the correct IP, if needed change the DNS www entry to point to the IP not the name. Also see to it that you have at least one MX(10) record pointing to "mail.yourdoamin.com"

    In mail enable admin:
    under SERVERS + LOCALHOST right click and choose properties, set the default post office to "yourdomain.com" and tick the box (obviously this domain needs to exist already on the plesk server)

    Under CONNECTORS choose SMTP right click and choose properties SMTP TAB:
    local doamin name= yourdoamin.com
    hostname = webone.yourdomain.com
    DNS should reflect accordingly, add more dns by leaving a space between them
    email address needs to be a local one, such as support@yourdomain.com (it needs to have a mailbox also)
    INBOUND TAB
    PORT 25
    ACCESS CONTROL = granted access
    all IP's including 127.0.0.1 should be bound
    OUTBOUND
    ADDRESS can be default or yourdomain.com (suggest default)
    RELAY = !use caution! enable mail relay checked, allow relay for auth senders and use mail enable settings, allow for privlaged ips should show denied access for all EXCEPT THE IPS ON YOUR SERVER including 127.0.0.1.
    I DO NOT RECCOMMEND USING THE FINAL TWO OPTIONS
    SECURITY TAB
    the 1st 3 options should be checked reject authenticated and require
    click the advanced button add 127.0.0.1 to that list
    Advanced SMTP TAB
    tick header fixing
    uncheck these smtp commands:
    EXPN AND VRFY

    The rest, like reverse dns back listing I would use, but use MAPS in plesk to set up your lists you want to use, I use these two ONLY:
    sbl.spamhaus.org;bl.spamcop.net

    last but not least:
    Check IIS manager in admin tools, the name you chose "webone" should show as the local computer, if so there ya go.

    ALSO:


    In plesk, and for "yourdoamin.com" add these two mailboxes POSTMASTER AND ABUSE" it's ok if they redirect or forward somewhere, but they need to exist.

    Check your event log for errors, do a reverse dns lookup and ptr look up for your domain at dnsstuff.com then do a DNS report from there also.

    Check your firewall software (make sure ports 25 and 110 are open along with dns port 53

    Dont use windows or plesk firewall, suggest black ice or tiny.

    Also suggest killing DR WEB and installing clam, (clamav-0.85.1-6.exe works with plesk)and if you have resident anti virus running be sure to exclude the mailenable folder from active scanning.


    Oh yeh
    the names I used here webone and yourdomain.com are obviosly NOT the ones your going to use yourdomain.com = your real domian and webone is your name choice for the machine
    Just incase


    Hope this helps everyone.

    Jim
     
Loading...