1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Mailbox is Full...

Discussion in 'Plesk for Linux - 8.x and Older' started by willlangford, Feb 6, 2005.

  1. willlangford

    willlangford Guest

    0
     
    Hello,
    I started getting an interesting error today. I upgraded to 752 from 751 on friday, but starting today i havnt been getting email. it is getting rejected saying that the mailbox is full. anyone got any ideas?

    Thanks,
    ~William
     
  2. ashleym

    ashleym Guest

    0
     
    I'm having the same problem.. Can send email, but can't receive it.

    "Recipient's mailbox is full, message returned to sender. (#5.2.2)"

    Any thoughts?
     
  3. ashleym

    ashleym Guest

    0
     
    Apparently the 7.5.2 upgrade set the mailbox quota for all of my accounts to 0 KBytes which was causing the email to bounce.

    After setting the mailbox quota to Unlimited it fixed the problem.

    Hope this helps you!
     
  4. willlangford

    willlangford Guest

    0
     
    i looked at some emails and the mailbox size was still set to unlimited. am i missing something?
     
  5. Ales

    Ales Basic Pleskian

    23
    73%
    Joined:
    Mar 4, 2002
    Messages:
    67
    Likes Received:
    0
    Did you check in Plesk or the actual .qmail files on the server...?

    We haven't upgraded any of our servers to 7.5.2 (too many bugs) so I can't check myself, but the correct numbers in Plesk's database don't always mean that it's really so...
     
  6. willlangford

    willlangford Guest

    0
     
    Nope, i just checked the gui. where are those files at, and what do i need to change?
    thanks,
    ~William
     
  7. earlmred

    earlmred Guest

    0
     
    I had the same problem, you need to remove all of the @mbox.quota files to fix this problem. None of your email accounts will have quotas but they will work again.

    find /usr/local/psa/home/vhosts -name '@mbox.quota' -exec rm {} \;

    The above command will remove all of the @mbox.quota files.

    Still looking to solve the problem of when clicking on domains under the admin interface, showing up blank ...

    7.5.2 on FreeBSD 4.10-p5
     
  8. willlangford

    willlangford Guest

    0
     
    help.....

    Im running redhat 9, and i am getting and error that the directory doesnt exist..
    any ideas?
    ~William
     
  9. jprince

    jprince Guest

    0
     
    Hello,
    Support has a response/fix for both items.

    Domains Blank:
    for FreeBSD, they have replaced the file:
    /usr/local/psa/admin/plib/class.DomainControlForm.php
    I would assume a hotfix would be available to correct this.
    Contact support for further info.

    The Mailbox full issue:
    Per support:
    "I can remember we had such issue long time ago.
    Mailboxes can be set to zero after upgrade from in old Plesk versions '0' means 'Unlimited', in Plesk 7 unlimited is '-1'"


    The only way to fix it is to replace '0' with '-1' in Plesk base, remove qmail quota files and re-run mchk
    1. update psa.mail table from mysql console:

      update mail set mbox_quota='-1'
      where postbox='true' and mbox_quota='0';

    2. remove current quotas from mail accounts in qmail in shell (one line command!):

      find /var/qmail/mailnames/ -name @mbox.quota
      -maxdepth 3 -mindepth 3 | xargs rm -f

      [post edited/changed]
      For FreeBSD:
      find /usr/local/psa/qmail/mailnames/ -name @mbox.quota
      -maxdepth 3 -mindepth 3 | xargs rm -f
      [end edit/change]

    3. run /usr/local/psa/admin/sbin/mchk -v to re-build quotas. Then restart qmail.
      [/list=1]
     
  10. Alasdair

    Alasdair Guest

    0
     
    Hi John,

    Would you be willing to post your new "/usr/local/psa/admin/plib/class.DomainControlForm.php" file? We contacted Sw-Soft about the issue however they haven't gotten back to us yet.

    Thanks in advance for any help you can provide.
     
  11. jprince

    jprince Guest

    0
     
    Hello,
    FreeBSD Only..
    The following file corrects the problem with
    blank domains.
    Note: While this file was provided to me by SW-Soft,
    I am not sure it should be posted. I have made a request
    to post this, and will await their answer.

    If you feel you need this file, send an email to me
    with your email address.
    <click on profile to send me an email>

    Cheers
     
  12. earlmred

    earlmred Guest

    0
     
    Unfortunately this didn't fix my issue, I've contacted bugreport@sw-soft.com but have yet to receive a reply.
     
  13. mOjO

    mOjO Guest

    0
     
    THANK YOU SO MUCH!

    that worked the treat... however for some reason i got errors from mchk about my rpm database. so i ran an rpm --rebuilddb and after that it went through ok.

    you saved me a LOT of frustration. :)

     
  14. Rick

    Rick Guest

    0
     
    I am having trouble with step one here.

    Logging into the mysql console with the admin account is no problem but when I issue the command...

    update mail set mbox_quota='-1'
    where postbox='true' and mbox_quota='0';

    I get an error that says...

    ERROR 1046: No Database Selected

    What am I doing wrong?

    Rick
     
  15. Rick

    Rick Guest

    0
     
    ok, nevermind, I figured it out.

    Anyone following these instructions please note a slight change in the syntax...

    update psa.mail set mbox_quota='-1'
    where postbox='true' and mbox_quota='0';

    I also got fatal errors on the rpm db and had to run a rebuild before step 3 would work...

    rpm --rebuilddb

    Thanks for the instructions, I would have fought this for days without them!

    Rick
     
Loading...