1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

maillog of 2GB - logrotate not working

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by ghazlewood, Mar 3, 2011.

  1. ghazlewood

    ghazlewood Basic Pleskian

    24
    40%
    Joined:
    Nov 15, 2004
    Messages:
    40
    Likes Received:
    0
    Location:
    London, UK
    I have a 9.2.1 CentOS 5 92090422.13 server which has a 2GB maillog file. For some reason logrotate isn't rotating this file.

    I've tried re-running the /usr/local/psa/admin/sbin/statistics command without any success
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
    Try to run

    # /usr/local/psa/bin/sw-engine-pleskrun /usr/local/psa/admin/plib/DailyMaintainance/script.php

    from /etc/cron.daily/50plesk-daily and check that it was logrotated.
     
  3. ghazlewood

    ghazlewood Basic Pleskian

    24
    40%
    Joined:
    Nov 15, 2004
    Messages:
    40
    Likes Received:
    0
    Location:
    London, UK
    OK running the command you suggest highlights that there are some databases which it cannot read properly.

    Looking at them they are only DBs with hypens in the name. I am renaming these databases, I remember reading a similar thread but did not realise that I too had databases with malformed names.

    I also get lots of

    Can I safely ignore these messages?
     
  4. ghazlewood

    ghazlewood Basic Pleskian

    24
    40%
    Joined:
    Nov 15, 2004
    Messages:
    40
    Likes Received:
    0
    Location:
    London, UK
    I still have an ever increasing maillog file even after correcting the database names. Any further suggestions please?
     
Loading...