1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Mailman: (de-)installation confusion

Discussion in 'Plesk for Linux - 8.x and Older' started by jonworth, Apr 1, 2006.

  1. jonworth

    jonworth Guest

    0
     
    I am running Plesk 7.5.4 on a 1&1 Root Server, SuSE Linux 9.3. Mailman was installed from the start, but failed to function properly.

    Perhaps wrongly I deleted the files for each of the mailing lists I created manually using FTP to see if the bugs were there - this made no difference.

    When I run the command to delete Mailman I get:

    Code:
    sXXXXXXX:/ # rpm -e mailman
    /var/tmp/rpm-tmp.18294: line 7: /etc/init.d/mailman: No such file or directory
    error: %preun(mailman-2.1.5-16.4) scriptlet failed, exit status 127
    i.e. the mailman files are deleted.


    When I enter the following SSH command to rebuild the rpm database:

    Code:
    rpm -vv --rebuilddb
    I get the following lines in the output:

    Code:
    D: adding "mailman" to Name index.
    D: adding 1979 entries to Basenames index.
    D: adding "Productivity/Networking/Email/Mailinglists" to Group index.
    D: adding 27 entries to Requirename index.
    D: adding "mailman" to Providename index.
    D: adding 130 entries to Dirnames index.
    D: adding 27 entries to Requireversion index.
    D: adding "2.1.5-16.4" to Provideversion index.
    This shows that rpm is still finding some reference to Mailman somewhere.


    Further, the Updater option in Plesk still lists that I have Mailman version 2.1.5-16.4 installed. This listing in the Plesk updater stays even if I delete the relevant line in the 'Compontents' table in the psa database. Further, if I reboot the server, Plesk automatically re-inserts the line in the table to state that Mailman 2.1.5-16.4 is installed.


    My question is hence this: where are these log files or whatever that contain the details of the remnants of the Plesk installation? And how can I delete them?

    Many thanks for any suggestions!
     
  2. pdreissen

    pdreissen Guest

    0
     
    Hi,

    Try to do
    rpm -qa |grep -i mailman

    And check if there are other "older" versions installed!
    Please remove them also!
     
  3. jonworth

    jonworth Guest

    0
     
    rpm -qa |grep result

    That gives:

    Code:
    sXXXXXXXX:/ # rpm -qa |grep -i mailman
    mailman-2.1.5-16.4
    
    Which is what would be expected...

    I just need to get rid of it now... As rpm -e does not work, what do I need instead? Sorry for my ignorance of rpm!
     
  4. dm__@

    dm__@ Guest

    0
     
    Buggy deinstall script. rpm -e --noscripts --notriggers mailman
     
  5. jonworth

    jonworth Guest

    0
     
    That's now working, but now there's an additional problem!

    Many thanks for those excellent replies! Mailman is now installed OK, and is accessible via Plesk.

    Mailman sends mails to confirm subscription, but it will not send on messages sent to the lists. However no errors at all appear in /var/lib/logs

    /var/lib/mailman/logs/smtp shows the following:

    Code:
    Apr 01 14:52:20 2006 (32398) <mailman.0.1143895938.32557.server-team@some-domain.de> smtp for 1 recips, completed in 0.062 seconds
    Apr 01 14:53:27 2006 (32398) <mailman.0.1143896005.32606.server-team@some-domain.de> smtp for 1 recips, completed in 0.038 seconds
    Apr 01 14:53:27 2006 (32398) <mailman.1.1143896005.32606.server-team@some-domain.de> smtp for 1 recips, completed in 0.111 seconds
    Apr 01 14:53:27 2006 (32398) <mailman.2.1143896005.32606.server-team@some-domain.de> smtp for 1 recips, completed in 0.179 seconds
    
    Any suggestions about what might be wrong here?

    I also notice that the Crontab list for user 'mailman' is empty in Plesk. Is that right?
     
  6. MacRonin

    MacRonin Guest

    0
     
  7. jonworth

    jonworth Guest

    0
     
    Cron-jobs for Mailman

    Hi MacCronin,

    It seems one hell of a package to install does Mailman! Anyway, let's see what we can manage via a cooperative effort!

    (1) What cron jobs are being run for your mailman installation? I presently have no cronjobs running. Can you maybe post the list of the cron jobs here?

    (2) What are the file ownerships / groups of your /var/lib/mailman files?

    (3) Do you get any error logs anywhere? Or do your messages just seem to disappear?

    I have essentially been using the same fix as TZ23 proposed in this thread:
    http://forum.swsoft.com/showthread.php?threadid=18130
    While that makes Mailman run, it will not deliver messages - presumably because of some cron job problems.
     
  8. MacRonin

    MacRonin Guest

    0
     
    Re: Cron-jobs for Mailman

    1-My maiman user doesn't have of its own cron jobs, but according to the log files, cron jobs under the mailman userID(auth) are being run every 5 minutes. They must enclosed in a general script being kicked off as needed.

    2- /var/lib/mailman files

    drwxrwsr-x 4 root mailman 4096 Mar 21 2005 archives
    drwxrwsr-x 2 root mailman 4096 Dec 24 03:10 data
    drwxrwsr-x 4 root mailman 4096 Mar 22 01:16 lists
    drwxrwsr-x 2 root mailman 4096 Mar 21 2005 spam

    March 21 is when I tried to create my first mailinglist.


    3-
    And I don't have the /var/lib/mailman/ logs/smtp you mention in your msg. mine is at /var/log/mailman/smtp

    and its msg contents seem OK
    Apr 02 23:21:14 2006 (26650) <mailman.0.1144034473.15029.listname@mysite.net> smtp for 1 recips, completed in 0.089 seconds

    And a few other log files but none of the contents jumps out at me. Primarily msgs about starting and stopping tasks.

    ls -al /var/log/mailman

    -rw-rw-r-- 1 root mailman 0 Apr 2 04:03 error
    -rw-rw-r-- 1 mailman mailman 3448 Apr 2 23:40 qrunner
    -rw-rw-r-- 1 mailman mailman 136 Apr 2 23:21 smtp
    -rw-rw-r-- 1 root mailman 82 Apr 2 23:21 subscribe

    There were also older archive versions that I removed from the list

    3b- I'm running python 234 and my Mailman will start (it does signup msgs) so this doesn't sound like one for me.

    My version of mailman is 2.1.5-32.fc3
     
  9. MacRonin

    MacRonin Guest

    0
     
    I don't know if you are still having the problem, but Since I hate to leave a question unanswered, I thought I'd pass along the final answer to my problem. It was a rather obscure quirk, but should be easy to check if you know about it.

    More details can be found at: http://faq.swsoft.com/article_61_942_en.html

    but here is an intro.

    Mailman can't send messages to subscribers with error: "Failure_to_exec_mailman_wrapper. WANTED_gid_110,_GOT_gid_101. (Reconfigure_to_take_101?)/did_0+0+1/"

    Product versions this article applies to:
    Plesk for UNIX (questions are not related to version) The latest update: Jan,23 2006



    1. Make sure that GID of user 'popuser' equals to 110 in /etc/passwd
    and /etc/group. If it doesn't, change it to 110. The lines in the files
    must be:

    /etc/passwd:
    popuser:x:110:110:pOP3 service user:/:/bin/false

    /etc/group:
    popuser:x:110:

    My mailman setup is now happily forwarding the incoming messages. I hope this helps someone.
     
  10. jonworth

    jonworth Guest

    0
     
    Finally a solution

    I've finally found the solution to my Mailman woes. I'll explain how I solved the problems here - might help others! I am running Plesk 7.5.4 on SuSE Linux 9.3, on a 1&1 Root Server .

    (1) FIrst of all, what was actually the error, and how could I find the right log where the error could be identified?

    The solution was to look in /var/log/mail.info where the following lines were found when a mail was sent to a mailman list:

    Code:
    May  6 18:06:34 sXXXXXXXX qmail: 1146931594.300776 new msg 16910050
    May  6 18:06:34 sXXXXXXXX qmail: 1146931594.300995 info msg 16910050: bytes 1421 from <jon@domain.com> qp 7431 uid 2020
    May  6 18:06:34 sXXXXXXXX qmail: 1146931594.318167 starting delivery 121073: msg 16910050 to local [email]1-server-list@domain2.com[/email]
    May  6 18:06:34 sXXXXXXXX qmail: 1146931594.318396 status: local 1/10 remote 2/20
    May  6 18:06:34 sXXXXXXXX qmail: 1146931594.381954 delivery 121073: success: Failure_to_exec_script._WANTED_gid_67,_GOT_gid_12./Failed_to_start_/usr/lib/mailman/mail/mailman./did_0+0+1/
    May  6 18:06:34 sXXXXXXXX qmail: 1146931594.382027 status: local 0/10 remote 2/20
    May  6 18:06:34 sXXXXXXXX qmail: 1146931594.382060 end msg 16910050
    This problem - of GID 67 / GID 12 is different from the GID issue discussed here:
    http://faq.swsoft.com/article_61_942_en.html

    Matz makes mention of it in this thread but without a comprehensive solution.

    (2) The GIDs 67 and 12 related to entries in /etc/group on my server. These were as follows:

    Code:
    mail:x:12:
    ...
    mailman:!:67:
    Mailman determines which GID to use from the file /etc/mailman/mailman.mail-gid

    (3) I hence de-installed Mailman using the command rpm -e mailman and deleted all of the mailman files on the server, including the mailing lists I had established.

    (4) I then made a fresh installation of Mailman using the Updater in Plesk, but before using Mailman, edited the file /etc/mailman/mailman.mail-gid and inserted the number 12 in that file, rather than 67.

    (5) I then setup the main e-mail address and password for Mailman in Plesk, and re-booted my server using the Plesk reboot function.

    (6) Having restarted the server, I allocated all of my domains the permission to create Mailing Lists (in 'Domains' > 'Group Operations' in Plesk) and proceeded to setting up mailing lists - everything worked.
     
Loading...