1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Manually enabling dot net 4.0 in your server with plesk 9.5.2

Discussion in 'Plesk 9.x for Windows Suggestions and Feedback' started by AminV, Jul 22, 2010.

  1. AminV

    AminV Guest

    0
     
    I need to enable manually .net 4.0 in my server by IIS. Is plesk will normally works with it? How can I switch manually to .net 4.0.

    Any solutions?
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,242
    Location:
    Novosibirsk, Russia
  3. AminV

    AminV Guest

    0
     
    I read it before but no useful information in that KB. Please provide a Plesk_Handler to handle .net 4.0. I think it's easier than you may imagine.

    I think should be a way to manually enable it. May be with defining a new wrapper handler!
     
  4. AminV

    AminV Guest

    0
     
    Ok, I think I should answer to myself here! Or learn you how you could handle dot net 4.0 here but I'm looking for better idea.

    1. Open your IIS Manager -> Handle Mappings -> Add script Map

    2. in "Edit Script Map" dialog fileds :

    Request Path : *.aspx

    Executable : %windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_isapi.dll

    Name : PageHandlerFactory-ISAPI-4.0

    3. IIS Manager -> Applications Pool -> (yoursite pool) and select .net 4.0 (Select Classic Mode)

    Test it now.

    It's only work manually and for IIS7 in classic mode.

    I'm waiting for any better idea.
     
  5. AminV

    AminV Guest

    0
     
    I find some other trick and I would like to share it with you. hope for your contributions.

    In classic mode you will have a problem with running MVC 2.0 and you should enabled wildcard script map as following:

    Here's how you enable a wildcard script map for IIS 7.0:

    1. Select your application in the Connections window
    2. Make sure that the Features view is selected
    3. Double-click the Handler Mappings button
    4. Click the Add Wildcard Script Map link
    5. Enter the path to the aspnet_isapi.dll file (You can copy this path from the PageHandlerFactory script map)
    6. Enter the name MVC
    7. Click the OK button

    * Don't forget to put "System.Web.Mvc.dll" in bin directiory of your web site.

    In this state (Classic mode) your web server preformance will be impact, So I'm looking for integerated mode. Any Idea?
     
  6. moonlight

    moonlight Guest

    0
     
    Manually enable dot net 4.0

    The is a way to enable .NET 4.0 manuelly by your ISP or by self if you have RDP access. It is posible to change it in the IIS Manager.

    But Notice this want break your ASP.NET settings in your Paralles Management for this domain!
     
Loading...