• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Maria DB not starting

xdelios

Basic Pleskian
I have a problem with mariadb.
I searched a bit in the forum and found some similar problems but still I cant solve it.

This is what I get.

Trying to start service mariadb... failed
* mariadb.service - MariaDB database server
Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Fri 2016-03-18 13:41:53 EET; 8ms ago
Process: 17553 ExecStartPost=/usr/libexec/mariadb-wait-ready $MAINPID (code=exited, status=1/FAILURE)
Process: 17552 ExecStart=/usr/bin/mysqld_safe --basedir=/usr (code=exited, status=0/SUCCESS)
Process: 17523 ExecStartPre=/usr/libexec/mariadb-prepare-db-dir %n (code=exited, status=0/SUCCESS)
Main PID: 17552 (code=exited, status=0/SUCCESS)

Mar 18 13:41:52 diamond.towerhost.gr mysqld_safe[17552]: Fatal error in defaults handling. Program aborted
Mar 18 13:41:52 diamond.towerhost.gr mysqld_safe[17552]: [76B blob data]
Mar 18 13:41:52 diamond.towerhost.gr mysqld_safe[17552]: Fatal error in defaults handling. Program aborted
Mar 18 13:41:52 diamond.towerhost.gr mysqld_safe[17552]: 160318 13:41:52 mysqld_safe Logging to '/var/lib/mysql/diamond.towerhost.gr.err'.
Mar 18 13:41:52 diamond.towerhost.gr mysqld_safe[17552]: 160318 13:41:52 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
Mar 18 13:41:52 diamond.towerhost.gr mysqld_safe[17552]: 160318 13:41:52 mysqld_safe mysqld from pid file /var/lib/mysql/diamond.towerhost.gr.pid ended
Mar 18 13:41:53 diamond.towerhost.gr systemd[1]: mariadb.service: control process exited, code=exited status=1
Mar 18 13:41:53 diamond.towerhost.gr systemd[1]: Failed to start MariaDB database server.
Mar 18 13:41:53 diamond.towerhost.gr systemd[1]: Unit mariadb.service entered failed state.
Mar 18 13:41:53 diamond.towerhost.gr systemd[1]: mariadb.service failed.


What should I do ?
 
Back
Top