1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Migration from 10.2.0 -> 10.3.0 - PHP not enabled / vhost.conf not sticking

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by Preston, Aug 16, 2011.

  1. Preston

    Preston Guest

    0
     
    I am having a strange problem with a particular site not having PHP enabled. I go and edit a vhost.conf or change the settings in the control panel to enable PHP but the settings never take place.

    What is the correct command and file structure for applying manual changes to a virtual host?

    The instructions here are what I am doing with no luck: http://ittips.bilardi.net/blog/2011/01/03/how-to-use-vhost-conf-in-plesk/

    I have to go in and manually change the /conf/*.include file and restart apache manually to get PHP to stay enabled.

    Do I need a php.ini? Is something stuck in the psa database that I need to fix that is left over from a previously failed import?

    I've never seen my changes not take affect.
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    What about /usr/local/psa/bin/domain utility with

    -php <true|false> PHP support

    option? (--help option for details)
     
  3. Preston

    Preston Guest

    0
     
    Wonderful!

    This worked great and solved my issues a lot faster than editing/creating a vhost.conf for all the sites I see errors for. I am still unable to successfully edit via the control panel but at least I can get PHP up quickly. Thank you.

     
Loading...