• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Migration from 10.2.0 -> 10.3.0 - PHP not enabled / vhost.conf not sticking

P

Preston

Guest
I am having a strange problem with a particular site not having PHP enabled. I go and edit a vhost.conf or change the settings in the control panel to enable PHP but the settings never take place.

What is the correct command and file structure for applying manual changes to a virtual host?

The instructions here are what I am doing with no luck: http://ittips.bilardi.net/blog/2011/01/03/how-to-use-vhost-conf-in-plesk/

I have to go in and manually change the /conf/*.include file and restart apache manually to get PHP to stay enabled.

Do I need a php.ini? Is something stuck in the psa database that I need to fix that is left over from a previously failed import?

I've never seen my changes not take affect.
 
What about /usr/local/psa/bin/domain utility with

-php <true|false> PHP support

option? (--help option for details)
 
Wonderful!

This worked great and solved my issues a lot faster than editing/creating a vhost.conf for all the sites I see errors for. I am still unable to successfully edit via the control panel but at least I can get PHP up quickly. Thank you.

# /usr/local/psa/bin/domain -u domain.com -php true
 
Back
Top