1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Migration Manager Errors

Discussion in 'Plesk for Linux - 8.x and Older' started by crazy4bass, Apr 21, 2005.

  1. crazy4bass

    crazy4bass Guest

    0
     
    Got everything upgraded to 7.5.2 fine and I just have the standard license, didn't spring for the addon package so this may be the cause of this problem but here goes.

    Used the updater to install the Migration Manager, it appears active in the CP but when you run it this is what you get:

    migrationmanagerfactory::fetchAttrsFromTable_() failed: migrationmanagerfactory: unable to select: Can't find file: 'PMM.MYI' (errno: 2)

    --------------------------------------------------------------------------------

    0: /usr/local/psa/admin/plib/PMM/MigrationManagerFactory.php:31 psaerror(string "migrationmanagerfactory::fetchAttrsFromTable_() failed: migrationmanagerfactory: unable to select: Can't find file: 'PMM.MYI' (errno: 2)")
    1: /usr/local/psa/admin/htdocs/server/PMM/index.php:8 migrationmanagerfactory->migrationmanagerfactory()

    Any ideas what this is about? btw: did upgrade to MySQL 4.0.20 but everything else seems to work just fine.

    Thanks
     
  2. 0031

    0031 Guest

    0
     
    Check that psa.PMM table exists

    mysql> show tables;

    and if not - create it

    mysql> CREATE TABLE PMM (param, val) TYPE=InnoDB;

    Or probably your database is corrupted? You also may drop PMM table and recreate it...
     
  3. juanchi

    juanchi Guest

    0
     
    I have the same error and I tried what you wrote but it didn't work, anyone know how to fix this, please.
     
Loading...