• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

migration problem please help

M

muradd

Guest
hi

am trying to migration from cpanel to plesk .. it's just one domain it's says it's complete but with error

it's use to work before .. i have the last plesk in openvz panel .. is there another way to migrate the server from backup for example please help the last company will close the server i need to move it fast

is this the log file

ERROR: () Domain 'kalemaro.com'will not be migrated due to errors above


ERROR: () XmlNode exception: Invalid XmlNode
Invalid XmlNode. Element 'domain': Attribute 'cgi_root' is required but isn't found:
-------- stacktrace start --------
XmlNode exception: Invalid XmlNode at Validator.pm line 260
Validator::verifyAttributeExists('XmlNode=HASH(0x9261678)', 'cgi_root') called at Validator.pm line 50
Validator::validateCpDomainNode('XmlNode=HASH(0x9261678)') called at Validator.pm line 41
Validator::validateCpAccountNode('XmlNode=HASH(0x91aa458)') called at Transformer.pm line 288
Transformer::getClientNode4Domain('kalemaro.com') called at Agent.pm line 97
Agent::getDomain('kalemaro.com', 'recursive', 'content', 1, 'HASH(0x915a428)') called at DumpComposer.pm line 274
DumpComposer::makeDomainNode('kalemaro.com', 'undef', 'undef', 'undef', 1) called at DumpComposer.pm line 159
DumpComposer::makeDump('/var/cache/20120206160513768', 'undef', 'undef', 'ARRAY(0x9191908)', 'undef', 'undef', 'undef', 1) called at /var/cache/20120206160513768/cPanel9.pl line 234
main::main() called at /var/cache/20120206160513768/cPanel9.pl line 257
-------- stacktrace end --------
------------ xml node ------------
<?xml version="1.0" encoding="UTF-8"?>
<domain name="kalemaro.com" www_root="/home/kalemaro/public_html">
<anonftp/>
<ftpuser password="$1$TYSBSRlR$74mAPkxRaqkWqPdatUfn//" name="kalemaro" shell="/bin/false"/>
<pdir name="public_html/forum/admincp" title="">
<pduser password="$apr1$nMbAaFLN$8AcTUjonYcVgI5gjF/i9w." name="asd010010asd"/>
</pdir>
<pdir name="public_html/forum/modcp" title=""/>
<subdomain name="pic" www_root="/home/kalemaro/public_html/pic">
<mail>
<default target="email">[email protected]</default>
</mail>
</subdomain>
<subdomain name="forum" www_root="/home/kalemaro/public_html/forum">
<mail>
<default target="fail"> No Such User Here</default>
</mail>
</subdomain>
<mail>
<mailname password="$1$TYSBSRlR$74mAPkxRaqkWqPdatUfn//" name="kalemaro" domainname="kalemaro.com"/>
<mailname quota="78643200" password="$1$iadfjK41$eEvVEkI9SEQPGW7yWGgI7/" name="adv" domainname="kalemaro.com"/>
<mailname quota="52428800" password="$1$5SSiA_8B$.xK7AyIaZQ11TqjdppGV/1" name="demo" domainname="kalemaro.com"/>
<mailname quota="31457280" password="$1$umsiKa1z$mvYIiSmKLkdtBhBvJ9yQG0" name="superstar" domainname="kalemaro.com"/>
<mailname quota="52428800" password="$1$OXxyx5Sl$Q79peieJLuZr/hyaRHUDw." name="news" domainname="kalemaro.com"/>
<default target="email">[email protected]</default>
</mail>
<database version="5.1" name="kalemaro_deco" type="mysql">
<dbuser name="kalemaro">
<password type="encrypted">*6B61E92B0856DF5552B380CEBBD07F0F1DA2ED98</password>
<accesshost>server.kalemaro.com</accesshost>
<accesshost>184.154.0.46</accesshost>
<accesshost>69.175.74.143</accesshost>
<accesshost>localhost</accesshost>
</dbuser>
<dbuser name="kalemaro_deco2">
<password type="encrypted">*9A692F7C4E5B7E6CA26AA23520299B7F6DC416FE</password>
<accesshost>184.154.0.46</accesshost>
<accesshost>server.kalemaro.com</accesshost>
<accesshost>localhost</accesshost>
<accesshost>69.175.74.143</accesshost>
</dbuser>
</database>
<database version="5.1" name="kalemaro_dirat" type="mysql">
<dbuser name="kalemaro">
<password type="encrypted">*6B61E92B0856DF5552B380CEBBD07F0F1DA2ED98</password>
<accesshost>server.kalemaro.com</accesshost>
<accesshost>184.154.0.46</accesshost>
<accesshost>69.175.74.143</accesshost>
<accesshost>localhost</accesshost>
</dbuser>
<dbuser name="kalemaro_diratt">
<password type="encrypted">*ABF8AB84E887384F5BBBEB6660B1430903C54BCB</password>
<accesshost>184.154.0.46</accesshost>
<accesshost>server.kalemaro.com</accesshost>
<accesshost>localhost</accesshost>
<accesshost>69.175.74.143</accesshost>
</dbuser>
</database>
<database version="5.1" name="kalemaro_ko127" type="mysql">
<dbuser name="kalemaro">
<password type="encrypted">*6B61E92B0856DF5552B380CEBBD07F0F1DA2ED98</password>
<accesshost>server.kalemaro.com</accesshost>
<accesshost>184.154.0.46</accesshost>
<accesshost>69.175.74.143</accesshost>
<accesshost>localhost</accesshost>
</dbuser>
<dbuser name="kalemaro_ko127">
<password type="encrypted">*E2887C27B5ADED8291EF0A72DA510E29644B5995</password>
<accesshost>184.154.0.46</accesshost>
<accesshost>server.kalemaro.com</accesshost>
<accesshost>localhost</accesshost>
<accesshost>69.175.74.143</accesshost>
</dbuser>
</database>
<database version="5.1" name="kalemaro_newsqa" type="mysql">
<dbuser name="kalemaro">
<password type="encrypted">*6B61E92B0856DF5552B380CEBBD07F0F1DA2ED98</password>
<accesshost>server.kalemaro.com</accesshost>
<accesshost>184.154.0.46</accesshost>
<accesshost>69.175.74.143</accesshost>
<accesshost>localhost</accesshost>
</dbuser>
<dbuser name="kalemaro_newsaqq">
<password type="encrypted">*EDF01A339DC709FF6AE498C6F633D9A59212D320</password>
<accesshost>184.154.0.46</accesshost>
<accesshost>69.175.74.143</accesshost>
<accesshost>server.kalemaro.com</accesshost>
<accesshost>localhost</accesshost>
</dbuser>
</database>
<database version="5.1" name="kalemaro_pic" type="mysql">
<dbuser name="kalemaro">
<password type="encrypted">*6B61E92B0856DF5552B380CEBBD07F0F1DA2ED98</password>
<accesshost>server.kalemaro.com</accesshost>
<accesshost>184.154.0.46</accesshost>
<accesshost>69.175.74.143</accesshost>
<accesshost>localhost</accesshost>
</dbuser>
<dbuser name="kalemaro_pic2">
<password type="encrypted">*0F8F9D6E17C7A496A6E17BF49F1D3EF9AD87A96A</password>
<accesshost>184.154.0.46</accesshost>
<accesshost>server.kalemaro.com</accesshost>
<accesshost>localhost</accesshost>
<accesshost>69.175.74.143</accesshost>
</dbuser>
</database>
<database version="5.1" name="kalemaro_shoort" type="mysql">
<dbuser name="kalemaro">
<password type="encrypted">*6B61E92B0856DF5552B380CEBBD07F0F1DA2ED98</password>
<accesshost>server.kalemaro.com</accesshost>
<accesshost>184.154.0.46</accesshost>
<accesshost>69.175.74.143</accesshost>
<accesshost>localhost</accesshost>
</dbuser>
<dbuser name="kalemaro_exstar">
<password type="encrypted">*6BB4837EB74329105EE4568DDA7DC67ED2CA2AD9</password>
<accesshost>184.154.0.46</accesshost>
<accesshost>localhost</accesshost>
<accesshost>server.kalemaro.com</accesshost>
<accesshost>69.175.74.143</accesshost>
</dbuser>
<dbuser name="kalemaro_shooort">
<password type="encrypted">*9061E75993F22BE0E23AD03CC7D04A92ABBE35EF</password>
<accesshost>69.175.74.143</accesshost>
<accesshost>184.154.0.46</accesshost>
<accesshost>localhost</accesshost>
<accesshost>server.kalemaro.com</accesshost>
</dbuser>
</database>
</domain>
----------------------------------
 
the problem not totally solved .. now i have problem with this after i reinstall plesk 10.31

WARNING: () Unable to find psql


ERROR: (hosting object 'kalemaro.com') The password was generated for system user 'kalemaro'. New password is 'xxxxxxxxxxxxx!'


ERROR: (hosting object 'kalemaro.com') Failed deployment of prot.directory forum/admincp (domain kalemaro.com)

ERROR: () Execution of /usr/local/psa/admin/plib/api-cli/protdir.php --create forum/admincp -domain kalemaro.com -type nonssl failed with return code 1.
Stderr is
Unable create protected dir: Unable to create protected directory:filemng failed: mkdir: cannot create directory `//var/www/vhosts/kalemaro.com/public_html/forum/admincp': File exists
filemng: Error occurred during /bin/mkdir command.




ERROR: (hosting object 'kalemaro.com') Failed deployment of prot.directory forum/modcp (domain kalemaro.com)

ERROR: () Execution of /usr/local/psa/admin/plib/api-cli/protdir.php --create forum/modcp -domain kalemaro.com -type nonssl failed with return code 1.
Stderr is
Unable create protected dir: Unable to create protected directory:filemng failed: mkdir: cannot create directory `//var/www/vhosts/kalemaro.com/public_html/forum/modcp': File exists
filemng: Error occurred during /bin/mkdir command.




ERROR: (database user object 'kalemaro_f') User 'kalemaro' of database 'kalemaro_dirat' was renamed to 'kalemaro_f'


ERROR: (database user object 'kalemaro_f8') User 'kalemaro' of database 'kalemaro_ko127' was renamed to 'kalemaro_f8'


ERROR: (database user object 'kalemaro_f8a') User 'kalemaro' of database 'kalemaro_newsqa' was renamed to 'kalemaro_f8a'


ERROR: (database user object 'kalemaro_f8a6') User 'kalemaro' of database 'kalemaro_pic' was renamed to 'kalemaro_f8a6'


ERROR: (database user object 'kalemaro_f8a63') User 'kalemaro' of database 'kalemaro_shoort' was renamed to 'kalemaro_f8a63'
 
Last edited by a moderator:
Back
Top