1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

missing install_form trying to install Drupal

Discussion in 'Plesk for Linux - 8.x and Older' started by Otter, Jan 30, 2008.

  1. Otter

    Otter Guest

    0
     
    I have tried to install several site apps including Drupal and Joomla and both fail with a PLESKFATALEXCEPTION missing install_form. I even got the latest and greatest ap.zip file for Drupal added it and it gets the same error.

    Was something not setup right in the intial PLESK install??
     
  2. unika

    unika Guest

    0
     
    Hi,
    now I can give you just the following recommendations:

    1) check that application vault package was updated in proped way on the server.
    Go to Server-> Updter -> Plesk 8.2 -> application vault - the package is up to date.
    in case there are other message - you should install the required package.

    2) in other case specify the exact error message and describe how you tried to install them.
     
  3. Otter

    Otter Guest

    0
     
    MYfindings

    Everything looks fine in Application Vault. It shows up in the list with the appropriate info.

    Following the 'accept GNU License' dialog and clicking next I get....


    ERROR: PleskFatalException
    Command not found: install_form

    0: /usr/local/psa/admin/plib/common_func.php3:156
    psaerror(string 'Command not found: install_form')
    1: /usr/local/psa/admin/plib/class.cList.php3:171
    cList->setFSP(string 'install_form')
    2: /usr/local/psa/admin/htdocs/domains/hosting/site_app_pkgs.php:111
    require(string '/usr/local/psa/admin/htdocs/domains/hosting/site_app_pkgs.php')
    3: /usr/local/psa/admin/htdocs/plesk.php:23
     
  4. Otter

    Otter Guest

    0
     
    Updater

    Looks fine for 8.2.1 "You have an up to date version". It does show a red exclamation point for 8.3.0 "Upgrading to the new control panel version" Does that indicate someone started, but aborted an upgrade?
     
Loading...