1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

multiple domains on one hosting

Discussion in 'Plesk for Linux - 8.x and Older' started by explido, Mar 23, 2005.

  1. explido

    explido Guest

    0
     
    Hello!

    Is it possible in any way to point multiple domains on one wehspace? So that "test1.de", "test2.de" and "test3.de" use the same content.

    I don't want to forward "test2.de" and "test3.de" to "test1.de".

    I hope you understand what I mean.

    Hope to hear from you soon.


    Best wishes from Germany,

    b.o. Marc Geldon
    (explido Software GmbH&Co.KG)
     
  2. alex042

    alex042 Guest

    0
     
    Plesk doesn't have domain aliasing, so you'll either have to manually add this or use the domain forwarding.
     
  3. explido

    explido Guest

    0
     
    But isn't that a standard feature on such configuration tools? I think Confixx does it. I think this is a standard feature!

    Is there a chance SWsoft implement this?


    Best wishes from Germany,

    b.o. Marc Geldon
    (explido Software GmbH&Co.KG)
     
  4. dukex

    dukex Guest

    0
     
    Just drop a vhost.conf in the domains conf folder use:

    ServerAlias Domainb.com
    ServerAlias www.Domainb.com


    then as root run

    /usr/local/psa/admin/sbin/websrvmng --reconfigure-vhost --vhost-name=<domain_name>

    replace <domain_name> with the domain you made the vhost.conf file for.

    This will reconfigure the httpd.include file for that domain, it will see the vhost.conf file you made and tell the httpd.include file to include the vhost.conf file

    after running this command you should be able to open the httpd.include file that is in the conf directory with the vhost.conf file and near the bottom you should see a include statement for the vhost.conf file

    then restart the httpd service and your done
     
  5. spandox

    spandox Guest

    0
     
  6. explido

    explido Guest

    0
     
    I know that I can edit the apache files. But what do I have PLESK for? I think PLESK should do that, I think that should be a standard feature.

    On Confixx for example this feature exists!


    Best wishes from Germany,

    b.o. Marc Geldon
    (explido Software GmbH&Co.KG)
     
  7. alex042

    alex042 Guest

    0
     
    You're right, this should be a standard feature thats already included in several other control panels, but then again, some like cpanel may have domain aliases, but don't have the domain forwarding options that plesk does. Plesk has an option to use inline frames to make it appear the domains are aliased when they're not.
     
  8. spandox

    spandox Guest

    0
     
    Sounds like an excuse

    A redirect in a web browser does, in no way, simulate a ServerAlias. The fact that it is one line in a vhosts file and then a rebuild just means that the Pleak people haven't really thought about it in the UI. Hopefully, knowing that it is only a minor change that doesn't even need much of an interface update, they will add it - in integrate it into the DNS and mail portions as well.

    Speaking of which, has anyone figured out a domain alias type of thing for mail in Plesk? I have experience with sendmail and postfix - never qumail.

    Anyone know if changing the /var/qmail/control/virtualdomains file is the key?
     
  9. edispah

    edispah Guest

    0
     
    Hi

    Ive been having the same problem and came across

    http://forum.ev1servers.net/showthread.php?t=55333

    In summary to add a mail domain alias

    1. Add the alias to /var/qmail/control/rcpthosts
    2. Edit /var/qmail/virtualdomains to add the domain e.g

    domain.com:[virtual#id]

    where "virtual#id" corresponds to the integer of the virtual domain that this domain is aliasing (this id is already specified in the same file).

    3. Restart qmail "service qmail restart"

    I tested on mine and seems to work fine.

    Paul
     
  10. spandox

    spandox Guest

    0
     
    Thank you

    I should have posted this awhile ago when I figured it out. You are exactly correct.
     
Loading...