1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

mysql issue

Discussion in 'Plesk for Windows - 8.x and Older' started by Shorts, May 5, 2005.

  1. Shorts

    Shorts Guest

    0
     
    I have just install the 7.5.2 update for Plesk and am now getting a mysql problem.

    When i go into Databases/mysql in the server name box has been grayed out and "(Name for the server cannot be changed: There is at least one database on the server)" put under the boxes.

    Then when i click on the MySql RootWebAdmin icon i get

    he host name is empty!
    Warning: Cannot modify header information - headers already sent by (output started at C:\Program Files\SWsoft\Plesk\admin\htdocs\domains\databases\phpMyAdmin\libraries\common.lib.php:1304) in C:\Program Files\SWsoft\Plesk\admin\htdocs\domains\databases\phpMyAdmin\libraries\select_theme.lib.php on line 104

    Warning: Cannot modify header information - headers already sent by (output started at C:\Program Files\SWsoft\Plesk\admin\htdocs\domains\databases\phpMyAdmin\libraries\common.lib.php:1304) in C:\Program Files\SWsoft\Plesk\admin\htdocs\domains\databases\phpMyAdmin\index.php on line 26

    Warning: Cannot modify header information - headers already sent by (output started at C:\Program Files\SWsoft\Plesk\admin\htdocs\domains\databases\phpMyAdmin\libraries\common.lib.php:1304) in C:\Program Files\SWsoft\Plesk\admin\htdocs\domains\databases\phpMyAdmin\index.php on line 42

    Fatal error: Call to undefined function: pma_dbi_get_dblist() in C:\Program Files\SWsoft\Plesk\admin\htdocs\domains\databases\phpMyAdmin\libraries\common.lib.php on line 1374

    all this was working fine before the update, any ideas

    Mike
     
  2. Shorts

    Shorts Guest

    0
     
    im sure this is a quick fix

    anybody
     
  3. acidbox

    acidbox Guest

    0
     
    I have the same issue =/
     
  4. Mnemonyss

    Mnemonyss Guest

    0
     
    For the header errors, to fix them open the index.php file up and remove the blank line or space on the line it specifies.

    For the last one I am still looking for the answer.
     
  5. acidbox

    acidbox Guest

    0
     
    I'm pretty sure the header errors are occuring because the script is outputting the text, "The host name is empty!" I still haven't fixed this issue, I had to install a new copy of phpMyAdmin on the side and do it that way.
     
  6. chartman

    chartman Basic Pleskian

    23
    57%
    Joined:
    Feb 24, 2005
    Messages:
    28
    Likes Received:
    0
    I am having the same problem as above, and am hoping that someone solves this one.
     
  7. igoldman

    igoldman Regular Pleskian

    26
    23%
    Joined:
    Sep 14, 2004
    Messages:
    212
    Likes Received:
    0
    the problem is because the mysql isn't configured correctly in plesk.

    what you have to do ?

    connect as admin
    go to databases
    the choose mysql
    and then edit the hostname to be localhost
    and the port to be 3306
    also enter the username and the password

    if you can't do that and it is appear to be in gray color and you can't edit it ,
    the only way to fix it is to connect to plesk database (not port 3306 , the database which plesk is working with for storing all the control panel information ) and edit manualy the table and go to the field where you enter the info about the mysql server application.

    hope that I helped you.
     
  8. chartman

    chartman Basic Pleskian

    23
    57%
    Joined:
    Feb 24, 2005
    Messages:
    28
    Likes Received:
    0
    Greetings:

    I tried your suggestions and got a JavaScript error message as follows.

    "Unable to update database parameters: Try to establish connection failed: Run-Time error: Failed to connect to database: Access denied for user admin@localhost (using password: YES)."

    Not sure what is going wrong. Possibilities might be...

    ODBC settings on the machine (outside of PLESK). Question: Does Plesk set up ODBC on the machine or does that have to be done manually?

    Is there a default password and user for the Plesk login to MySqL?

    Not sure what else it could be. Your thoughts.

    Chartmen
     
  9. botsman

    botsman Guest

    0
     
    Hi guys... I reccomend to upgrade your plesk up to 7.5.3 since as I know 7.5.2 has some problems with IIS.

    As for the current problem it can be that root(admin) user has no appropriate privileges.
    Try to login to mysql and grant him all privileges with command:

    grant all privileges on *.* to 'root'@'localhost' identified bt 'root_password';

    Note : root user is the user which can be set in psa>server>databases
     
  10. botsman

    botsman Guest

    0
     
    Just in addditional.

    Check also "misc" table of psa dtabase that parameters "mysql_data_source" and mysql_port" have correct valuse, i.e. localhost and 3306.
    If no, set them.
     
  11. andyslater

    andyslater Guest

    0
     
    Hey,

    ive got the same problem as the guys above,

    Ive upgraded to pleask 7.5.5 and this hasnt solved the problem, ive also downloaded a mysql admin tool but i cant find the database where the plesk details are stored.

    Is there a seperate location for the pleask database? with the parameters for the program in?

    Surely someone has a simple solution to this problem as the database is there but because the fields in plesk are disabled we cant edit them. :(

    Please help.

    Andy
     
  12. matija

    matija Guest

    0
     
    The solution to this problem is to edit php.ini file in Windows root (eg. C:\Windows\php.ini) and replace string

    output_buffering = Off

    to:

    output_buffering = On

    Note: If using latest version of phpMyAdmin (v2.7.0-rc1) it still gives an error "The host name is empty!", but v2.6.4-pl4 will work fine.
    If you want to update your version of phpMyAdmin, just replace the files from new version over the existing ones located in Plesk directory (eg. C:\Program Files\Plesk\admin\htdocs\domains\databases\phpMyAdmin) except config.inc.php which you have to leave intact.
     
Loading...