1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

mysql not working since upgrade

Discussion in 'Plesk for Linux - 8.x and Older' started by rookie00, Jul 26, 2006.

  1. rookie00

    rookie00 Guest

    0
     
    i upgrade to mysql from 3.23 to 4.1.20 lastnight and all was working before i upgrade. but now i am getting a mysql error.
    i am using fedora 2, plesk 7.5.4. i also tried to restart mysql but when i try it says it failed to restart. anyway i can fix this.

    Mysql Error : Connection Error
    Error Number: 2002 Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (111)

    any suggestion please. thanks
     
  2. wagnerch

    wagnerch Guest

    0
     
    Did you verify that no mysql processes were running? Is the /var/lib/mysql directory owned by the mysql user and mysql group? All of the files should also be owned by mysql.

    chown -R mysql:mysql /var/lib/mysql


    You can also verify the settings that mysqld would use for startup by running "mysqld --verbose --help".

    You may need to set the "old-passwords" option in the my.cnf file -- unless you have dealt with that problem as well. I have 5 different versions of mysql installed, but they are all in different paths with independent UNIX sockets and mysql data directories.
     
  3. rookie00

    rookie00 Guest

    0
     
    i tried all ur suggestion except the one that check the settings seems like that's a bad command and it still doesn't work.
    i did a "service mysql start" and says mysql:unrecognize service. also i check mysql.sock and it says "unknown file size".
    is there a way i can go back to 3.23 and start over again.
     
Loading...