1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

.net 4 on windows 2003

Discussion in 'Plesk 10.x for Windows Issues, Fixes, How-To' started by AliZ, Mar 13, 2011.

  1. AliZ

    AliZ Basic Pleskian

    17
    85%
    Joined:
    Jun 28, 2010
    Messages:
    33
    Likes Received:
    0
    Hello,

    I have plesk 10.0.1 on Windows 2003,

    I Installed the .net 4 on the server and I can see in:

    Settings > asp.net Settings that my current asp.net version is: 4.0.30319.1

    also i can Set the asp.net version for the web site from IIS to 1,2 and 4


    but there is no option in the clients panel to switch their asp.net version to 4, only version 1 and 2 are appered in the clients panel,

    is there any settings to enable clients to swtitch to .net 4?


    Thanks
     
  2. PavelV

    PavelV Plesk for Windows Staff Member

    28
     
    Joined:
    Nov 15, 2010
    Messages:
    251
    Likes Received:
    15
    I log in as client to Control Panel. Open Websites and Domains tab, click on domain name in list on bottom of page.
    Hosting settings screen opened. Here I can select version of ASP.NET including 4.0

    See my screenshot.

    Where are you trying to change version?
     

    Attached Files:

  3. AliZ

    AliZ Basic Pleskian

    17
    85%
    Joined:
    Jun 28, 2010
    Messages:
    33
    Likes Received:
    0
    Pavel, Thanks you for your replay

    This is what I see in my Admin Panel for asp.net settings:

    [​IMG]

    and this is what shows in my clients panel:

    [​IMG]

    I don't know what is wrong with it.
     
  4. PavelV

    PavelV Plesk for Windows Staff Member

    28
     
    Joined:
    Nov 15, 2010
    Messages:
    251
    Likes Received:
    15
    Go to Settings->Server components and check if ASP.NET 4 exists in Web Scripting section. Then click Refresh on this page. It should be detected after that. see screenshot for reference.

    Do you have .NET framework 4 installed after Plesk installation? if yes, then take into account, that after installation of any 3-rd party solution supported by Plesk, you should refresh your components configuration as I've described above.
     

    Attached Files:

Loading...