1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Network Address Translation - NAT

Discussion in 'Plesk for Windows - 8.x and Older' started by jfolker, Sep 23, 2004.

  1. jfolker

    jfolker Guest

    0
     
    OK, i'm trying to get plesk to run behind a NAT network, and it's giving me fits. I was able to change the DNS master record in the database to point to my outside IP, including the PTR record, but when I add a domain it gets the internal IP as the PTR record.

    How do I get it to work? Has anyone run Plesk behind NAT succeesfully?

    Win2k3 is the oS

    P.S. In order to change the main domain A record i had to go into mySQL db of Plesk.
     
  2. jfolker

    jfolker Guest

    0
     
    ** bump **

    I KNOW i'm not the only one with this issue.

    It's assigning my internal IP to the PTR record when I create the domain, which is an issue. I do have my external IP as the PTR record in my DNS master template, but Plesk sees my interal IPs in the control panel and when i create a domain with physical hosting it makes the PTR record for that domain my internal IP.

    ...

    Help!
     
  3. jfolker

    jfolker Guest

    0
     
    i'll post my reply, because I want to help others out with similar issues.

    There are two options, I HAVE NOT tested the second one.

    1-Change the master DNS and then manually change the PTR record of each new domain.

    2-Add your external addresses to the control panel and it should use them. Add them through the control panel interface. I DO NOT recommend removing your internal addresses from this, I do not know the implications. [As a side note, I just tested this mid-authoring and it seems to work ok; it's just the "official" answer from Plesk support]
     
  4. webyhost

    webyhost Guest

    0
     
    I ran into this same issue since I am ussing nat.

    One major problem I came accross is when the domain is created in IIS the listen ip is public.

    Therefore the website cannot be located unless you manually ad the private ip.

    I am beginning to think that it may be best to put the servers on the outside an assign them a public IP.

    I will ask plesk tech support and reply.

    thanks

    Jorge
     
  5. quabbo

    quabbo Guest

    0
     
    Any luck? I am having similar problems with NAT and Plesk 7.1.5 on FreeBSD.
     
  6. webyhost

    webyhost Guest

    0
     
    Unfortunately no.

    I ended up making the plesk servers public and I left my other servers on nat.
    I don't think plesk has the ability for proper natting.

    The best way is to go public especially if you want to automate the whole user sign up process.

    You should be able to sort this out with your router.

    Jorge
     
Loading...