• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

New Box MySQL out of space?

DaGeek

New Pleskian
I have a brand new box. After loading a few SMALL sites ( 5 or 6), Plesk fails with:

ERROR: PleskFatalException
Unable to connect to database: mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

0: common_func.php3:150
psaerror(string 'Unable to connect to database: mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)')
1: auth.php3:107
ERROR: PleskFatalException
Unable to connect to database: mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

0: common_func.php3:150
psaerror(string 'Unable to connect to database: mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)')
1: auth.php3:107



I did some digging and found that mysql is out of space??? Again - BRAND NEW BOX...

Tailing the mysql error log:
[root@hosting ~]# tail /var/log/mysqld.log
120512 18:22:26 [ERROR] /usr/libexec/mysqld: Error writing file '/var/run/mysqld /mysqld.pid' (Errcode: 28)
120512 18:22:26 [ERROR] Can't start server: can't create PID file: No space left on device
120512 18:22:26 mysqld_safe Number of processes running now: 0
120512 18:22:26 mysqld_safe mysqld restarted
120512 18:22:26 InnoDB: Initializing buffer pool, size = 8.0M
120512 18:22:26 InnoDB: Completed initialization of buffer pool
120512 18:22:26 InnoDB: Started; log sequence number 0 11894907
120512 18:22:26 [ERROR] /usr/libexec/mysqld: Error writing file '/var/run/mysqld /mysqld.pid' (Errcode: 28)
120512 18:22:26 [ERROR] Can't start server: can't create PID file: No space left on device
[root@hosting ~]# yum clean all
rpmdb: write: 0x1bff110, 8192: No space left on device
Bus error


Before I have them rebuild the server - yet again - does anyone have any suggestions?

Thanks,
Brian
 
Did you try to check free diskspace and inodes on partitions of your server with 'df' and 'df -i' commands?
 
Back
Top