• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Issue Nginx error

bokken

Basic Pleskian
Hello, i having problems with my nginx in plesk.

I installed the nginx but i have this error:

[root@server bin]# /usr/local/psa/admin/sbin/nginxmng -e
[2016-06-28 12:52:58] ERR [util_exec] proc_close() failed ['/usr/local/psa/admin/bin/nginx-config' '-t'] with exit code [1]
Error occured while sending feedback. HTTP code returned: 502
[2016-06-28 12:52:59] ERR [util_exec] proc_close() failed ['/usr/local/psa/admin/bin/nginx-config' '-t'] with exit code [1]
Error occured while sending feedback. HTTP code returned: 502
[2016-06-28 12:53:00] ERR [panel] Apache config (14671111780.84528000) generation failed: Template_Exception: nginx: [emerg] bind() to [2a01:4f8:xxxxxxxxxxx]:80 failed (99: Cannot assign requested address)
nginx: configuration file /etc/nginx/nginx.conf test failed

file: /usr/local/psa/admin/plib/Template/Writer/Webserver/Abstract.php
line: 75
code: 0
Error occured while sending feedback. HTTP code returned: 502
nginx: [emerg] bind() to [2a01:4f8:172:22d2::2]:80 failed (99: Cannot assign requested address)
nginx: configuration file /etc/nginx/nginx.conf test failed



/etc/init.d/nginx start

messages log:

Jun 28 12:54:12 server systemd: Starting Startup script for nginx service...
Jun 28 12:54:12 server test: /usr/bin/test: missing argument after ‘yes’
Jun 28 12:54:12 server systemd: nginx.service: control process exited, code=exited status=2
Jun 28 12:54:12 server systemd: Failed to start Startup script for nginx service.
Jun 28 12:54:12 server systemd: Unit nginx.service entered failed state.
Jun 28 12:54:12 server systemd: nginx.service failed.

What its the problem?
 
If you try to use "99: Cannot assign requested address" phrase for KB search, you will see a lot of related articles. Have you tried?
 
Make sure that nginx is completely stopped. After that check output of the following command:

# lsof -i tcp:80
 
Back
Top