1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

nginx won't start - getsebool: SELinux is disabled

Discussion in 'Plesk 11.x for Linux' started by JMB8877, Jul 7, 2012.

  1. JMB8877

    JMB8877 New Pleskian

    22
    23%
    Joined:
    Dec 12, 2006
    Messages:
    7
    Likes Received:
    0
    Location:
    United Kingdom
    Hi,

    Hopefully someone can shed some light on this...

    I've upgraded my Centos 5.8 box from Plesk 10.4.4 to 11.0.9 Update #4. I installed nginx with the Parallels installer, but I can't get nginx to start.

    When turing on the service through the Services Management panel, I receive the following error:

    Error: Unable to make action: Unable to manage service by nginxmng: Empty error message from utility. ('--enable', 'nginx')

    When running '/usr/local/psa/admin/bin/nginxmng --enable' on the command line it returns:

    getsebool: SELinux is disabled

    Any help with this would be much appreciated.

    Cheers,

    J
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,547
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    Do you have psa-selinux package installed? Try to reinstall it.
     
  3. JMB8877

    JMB8877 New Pleskian

    22
    23%
    Joined:
    Dec 12, 2006
    Messages:
    7
    Likes Received:
    0
    Location:
    United Kingdom
    Hi Igor,

    Thanks for the reply. The psa-selinex package was installed, so I tried to reinstall it with rpm and I got this output:

    semodule: SELinux policy is not managed or store cannot be accessed.
    semodule: SELinux policy is not managed or store cannot be accessed.
    getsebool: SELinux is disabled
    Shutting down kernel logger: [PASSED]
    Shutting down system logger: [ OK ]
    Starting system logger: [ OK ]
    Starting kernel logger: [PASSED]
     
    Last edited: Jul 9, 2012
  4. Nikolay.

    Nikolay. Silver Pleskian

    17
    35%
    Joined:
    Jul 1, 2012
    Messages:
    844
    Likes Received:
    2
    I suppose it's just a warning (due to SELinux being disabled on your machine).

    To look into the real cause try to: 1) run nginxmng --enable 2) look at and post here the latest log matching /tmp/nginx_proxy.log.*
     
  5. JMB8877

    JMB8877 New Pleskian

    22
    23%
    Joined:
    Dec 12, 2006
    Messages:
    7
    Likes Received:
    0
    Location:
    United Kingdom
    Thanks for the reply Nikolay.

    Here is the contents of the nginx_proxy.log:

    Checking for the group 'psaserv'...
    Trying to add supplementary group 'psaserv' for user 'nginx'... done
    Switching Apache ports in config files using mapping '80:7080,443:7081'
    Apache config file backups will be saved to '/tmp/nginx_proxy_backups.v13426'
    Updating '/etc/httpd/conf.d/ssl.conf'.
    Performing add of Apache RPAF module
    Performing add of Apache aclr2 module
    Switching NGINX rc enabled state to 'yes'
    Switching Apache ability to bind to any port (SELinux) to 1
    Warning: SELinux boolean httpd_can_bind_all_ports not found. Is plesk.pp policy installed?
    Doing NGINX stop
    Doing Apache restart
    Doing NGINX start
    Service /etc/init.d/nginx failed to start
     
  6. Nikolay.

    Nikolay. Silver Pleskian

    17
    35%
    Joined:
    Jul 1, 2012
    Messages:
    844
    Likes Received:
    2
    What is the output of 'getenforce' command? Check that Plesk policy is really installed via 'semoule -l | grep plesk'.

    Why nginx haven't been able to start? See in /var/log/nginx/error.log. Most probably it didn't succeed in binding to port 80 or 443. If so, the next step will be to determine why Apache is still bound to these ports. Check 'Listen' directives in your Apache configuration.
     
  7. JMB8877

    JMB8877 New Pleskian

    22
    23%
    Joined:
    Dec 12, 2006
    Messages:
    7
    Likes Received:
    0
    Location:
    United Kingdom
    Thank you Nikolay! It was a 'Listen' directive in my Apache conf that was set to the IP of the server. I removed the IP, just leaving the port number (80) and nginx started up straight away. No error messages about SELinux either.

    Thank you so much for your help with this!

    Cheers,

    J
     
Loading...