• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

no accessible config files for 'action.d/sendmail-whois'

finbarr69

Basic Pleskian
Suddenly Fail2Ban will no longer start.

I just noticed the following errors ([email protected] is obfuscated for this post)

Error: Unable to save the settings: f2bmng failed: ERROR Found no accessible config files for 'action.d/sendmail-whois' under /etc/fail2ban
ERROR Error in action definition sendmail-whois[name=plesk-proftpd, [email protected], [email protected], sendername="Fail2Ban"]
ERROR Errors in jail 'plesk-proftpd'. Skipping...
ERROR Error in action definition sendmail-whois[name=plesk-postfix, [email protected], [email protected], sendername="Fail2Ban"]
ERROR Errors in jail 'plesk-postfix'. Skipping...
ERROR Error in action definition sendmail-whois[dest="[email][email protected][/email]", sendername="Fail2Ban", sender="[email][email protected][/email]", name="plesk-dovecot"]
ERROR Errors in jail 'plesk-dovecot'. Skipping...
ERROR Error in action definition sendmail-whois[name=plesk-horde, [email protected], [email protected], sendername="Fail2Ban"]
ERROR Errors in jail 'plesk-horde'. Skipping...
ERROR Error in action definition sendmail-whois[dest="[email][email protected][/email]", sendername="Fail2Ban", sender="[email][email protected][/email]", name="plesk-roundcube"]
ERROR Errors in jail 'plesk-roundcube'. Skipping...
ERROR Error in action definition sendmail-whois[name=plesk-panel, [email protected], [email protected], sendername="Fail2Ban"]
ERROR Errors in jail 'plesk-panel'. Skipping...
ERROR Error in action definition sendmail-whois[name=SSH-iptables, [email protected], [email protected], sendername="Fail2Ban"]
ERROR Errors in jail 'ssh-iptables'. Skipping...
ERROR:f2bmng:Failed to start fail2ban service

These should be built-in rules. Any ideas how to fix this? Plesk uses postfix, but this used to work ok. I did do a "yum update" sometime ago -- I assume that is ok to do? Perhaps "yum update" interferes with Plesk's own update system?

Thanks

Brian
 
I copied sendmail-whois* from a backup into /etc/fail2ban/action.d/ and this fixed it. The mystery is why these files disappeared in the first place.
 
Back
Top