1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Node migration-dump does not have attribute dump-version

Discussion in 'Plesk for Linux - 8.x and Older' started by loziju, Mar 9, 2008.

  1. loziju

    loziju Guest

    0
     
    I have difficulty in restoring plesk 8.0 backup file in the new plesk 8.3 environment.

    I followed the backup and restore procedure mentioned inside the plesk document. However when I tried to restore my backup in the new server, it gives this error:

    Code:
    # /usr/local/psa/bin/pleskrestore --restore total.backup -level all -map total.backup.map
    ------------------------------------------------------------------------
    Restore has been started
    ------------------------------------------------------------------------
    Elapsed time: 00:00:00
    WARNING! Restore with "-level server" switch brings server to exactly the same
    state, as was saved in backup file. All objects, not presented in the backup
    file (clients or domains) will be deleted. Proceed? [yes/no]: yes
    
    Elapsed time: 00:00:08[COLOR="Red"]Node migration-dump does not have attribute dump-version[/COLOR]
    Does anyone know how to fix this? Thanks in advance for any help.
     
  2. loziju

    loziju Guest

    0
     
    Here's additional info.

    When I ran pleskrestore --info , it didn't show the dump version. But I did backup in plesk 8.0. Is this the reason for the error that I got?

    Code:
    # /usr/local/psa/bin/pleskrestore --info total.backup
    ------------------------------------------------------------------------
    Backup information
    Dump version:
    File: /home/loz/total.backup
    Type: Server
    Comment:
    Date: Mar 9, 2008 08:57 AM
    Size: 762 M
    ------------------------------------------------------------------------
    [Client] shop
      [Domain] shopperparade.com
      [Domain] ice3cafe.com
      [Domain] cupiecutie.com
    [Client] signs
      [Domain] fastfashion.com
      [Domain] signs.sg
    [Client] philip
      [Domain] classicsdvds.com
    
    I did try to use backup-convert, in case my backup was done in plesk 7.x. It didn't work.

    Any ideas anyone?
     
  3. futuredude

    futuredude Guest

    0
     
    I am also having same problem, anybody have info to offer?

    I performed a backup of Plesk v8.0.1 domain and now attempting to restore on new Plesk v8.3 (had to reinstall Plesk on same server due to catastrophic HW failure, got free upgrade from 8.0.1 to 8.3), received the error "Node migration-dump does not have attribute dump-version".

    Pleskrestore -i shows:

    ------------------------------------------------------------------------
    Backup information
    Dump version:
    File: /var/pathtofile/domainbackupfile_2008.03.30_05.35
    Type: Domain
    Comment: domain.com backup.Creation date: Mar 30, 2008 05:35 AM
    Date: Apr 3, 2008 10:43 AM
    Size: 122 M
    ------------------------------------------------------------------------

    Note that no dump version for this file was displayed.

    I then replaced the Deployer file as detailed in this thread . Performed the restore procedure once again and received the following error:

    Traceback (most recent call last):
    File "/usr/local/psa/admin/share/supervisor/processor.py", line 116, in doActivityRunner
    newState = self.doActivity()
    File "/usr/local/psa/admin/share/supervisor/processor.py", line 817, in doActivity
    cmd.spawn(os.environ.has_key("PLESKRESTORE_MODE"))
    File "/usr/local/psa/admin/lib/python/subproc.py", line 238, in spawn
    proc.run()
    File "/usr/local/psa/admin/lib/python/subproc.py", line 193, in run
    BaseSubprocess.run(self)
    File "/usr/local/psa/admin/lib/python/subproc.py", line 177, in run
    self.wait()
    File "/usr/local/psa/admin/lib/python/subproc.py", line 197, in wait
    BaseSubprocess.wait(self)
    File "/usr/local/psa/admin/lib/python/subproc.py", line 187, in wait
    raise NonzeroExitException(self, os.WEXITSTATUS(status))
    NonzeroExitException: was finished with exit code 127

    Confirmed "Package python - 2.5-15.fc7.i386 is already installed."

    Ran yum install perl.

    Updated: perl.i386 4:5.8.8-28.fc7
    Dependency Updated: perl-CPAN.i386 0:1.76_02-28.fc7 perl-ExtUtils-Embed.i386 0:1.26-28.fc7 perl-ExtUtils-MakeMaker.i386 0:6.30-28.fc7 perl-Test-Harness.i386 0:2.56-28.fc7 perl-Test-Simple.i386 0:0.62-28.fc7 perl-devel.i386 4:5.8.8-28.fc7 perl-libs.i386 4:5.8.8-28.fc7

    Performed another restore attempt, but same failure.

    I changed the owner of the /var/lib/psa/dumps/ folder to psaadm. I can create new backups without any problem, just cannot restore domains from previous 8.0.1 backup files. I am also unable to extract the existing 8.0.1 backup. The primary backup I'm attempting to restore is 122 Mbs in size.

    The agent-runner.log file shows "2008-04-03 21:11:47,837 INFO PacketServer bound to socket /usr/local/psa/tmp/agent-runner.13859". There is no supervisor.log file on the server.

    Research found similar errors on the following Plesk forum threads, but still haven't been able to resolve:

    http://forum.swsoft.com/showthread.php?t=50069&highlight=restore
    http://forum.swsoft.com/showthread....xitException:+was+finished+with+exit+code+127
    http://forum.swsoft.com/showthread....xitException:+was+finished+with+exit+code+127
    http://forum.swsoft.com/showthread.php?t=50246&highlight=restore
    http://forum.swsoft.com/showthread.php?t=52015&highlight=restore
    http://forum.swsoft.com/showthread.php?t=52032&highlight=restore



    I am stumped for answers and have scoured this forum for clues. Quite desperate at this point and would appreciate any advice offered.
     
Loading...