1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Open DNS servers

Discussion in 'Plesk for Linux - 8.x and Older' started by swgatl, Apr 25, 2006.

  1. swgatl

    swgatl Guest

    When I do a dnsreport on any of the domains hosted on my server at http://www.dnsreport.com I get an fail error on the Open DNS servers part.

    ERROR: One or more of your nameservers reports that it is an open DNS server. This usually means that anyone in the world can query it for domains it is not authoritative for (it is possible that the DNS server advertises that it does recursive lookups when it does not, but that shouldn't happen). This can cause an excessive load on your DNS server. Also, it is strongly discouraged to have a DNS server be both authoritative for your domain and be recursive (even if it is not open), due to the potential for cache poisoning (with no recursion, there is no cache, and it is impossible to poison it). Also, the bad guys could use your DNS server as part of an attack, by forging their IP address. Problem record(s) are:

    Server ***.***.**.66 reports that it will do recursive lookups. [test]
    Server **.***.**.67 reports that it will do recursive lookups. [test]

    See this page for info on closing open DNS servers.

    I'm not sure what I need to do about this because my 7.5.4 server didnt have this problem. It only started when I moved to my new server with 8.0.

    Any ideas on how to fix this on a live server?

  2. crossconnect

    crossconnect Guest

    You need to add the following line to the options section in your /etc/named.conf file:

    allow-recursion {;; };

    This prevents access for resolving DNS to only those addresses/networks listed - customise as necessary. You may want at least but if you don't want anything then enter:

    allow-recursion { none; };

    Plesk shouldn't overwrite anything in the options section.
  3. WebDork

    WebDork Guest

    Thanks :)