• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Resolved OSError: [Errno 2] No such file or directory

Wendykiller12

New Pleskian
Hi everyone, I am wondering if I could get a bit of support with an issue.

We're currently running plesk 12.5.30 on CentOS. Today when trying to issue a letsencrypt certificate to a server I have received an error stating the above error. I also states that 'Renewal conf file /usr/local/psa/modules/letsencrypt/etc/renewal/servername' is broke. skipping'.

Our Linux guy left on Friday and I only have limited knowledge, I have been unable to resolve it so far.. I am wondering if I can get some guidance to sort this problem please.
 
- Is the Let's Encrypt extension still installed?
- Where exactly/after what action is the "OSError: [Errno 2] No such file or directory" error displayed?
- Is /usr/local/psa/modules/letsencrypt/etc/renewal the correct path or is it /usr/local/psa/var/modules/letsencrypt/etc/renewal?
- Does that path actually exist on the hard disk? Do you find any .conf files in it or is it empty?
 
Back
Top