1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Outgoing mail error (#5.1.2) -- resolv.conf?

Discussion in 'Plesk for Linux - 8.x and Older' started by zrcs, Jun 21, 2007.

  1. zrcs

    zrcs Guest

    0
     
    Since migrating to a new block of IPs on a shared hosting box running Plesk 8.1.1 and CentOS 4.3, our clients are complaining of getting mail rejection errors for messages that they send to certain domains.

    Qmail is generating #5.1.2 errors (which the logs are full of) for these domains, although they are live, working remote domains that respond to nslookup, dig, and host (although not ping), and have clean dnsreports. Also, prior to changing our IPs, our server was sending mail to these domains without incident.

    I've surfed the forums for hours here, trying a variety of seemingly applicable solutions, including adding the -Rt0 flag, checking reverse DNS configuration and adding SPF records to all mail domains. Antivirus is off, Spamassassin is disabled, MAPS protection is off, and relaying is set to "closed" (using authentication was causing messages to AOL, SBC, and others to pile up in our queue).

    ...and the problem continues. I'm wondering if there might be an issue with the server's resolv.conf, but both nameserver IPs listed there respond quickly.

    I would be very appreciative if anyone could provide a possible solution.

    Thanks.
     
  2. poke

    poke Guest

    0
     
    does the rDNS on the new IP(s) match that of the mail server's hostname?

    Or did your hostname change perhaps?

    Just an idea..

    Good Luck ;)
     
  3. zrcs

    zrcs Guest

    0
     
    It turns out that the problem was somehow being caused by the recursion switches in named.conf. The "allow-recursion" and "recursion" settings were contradictory, i.e., recursion was turned off completely, but local recursion was switched on. Switching recursion on seems to have fixed the problem.
     
Loading...