1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

outgoing mail stuck due to spamassassin

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by jorge ceballos, Jun 9, 2010.

  1. jorge ceballos

    jorge ceballos Basic Pleskian

    25
    73%
    Joined:
    Mar 24, 2009
    Messages:
    65
    Likes Received:
    1
    Location:
    Mexico City
    Hi,
    Have a server using Plesk 9.5.2 completely updated using qmail and atomic's spamassasin along with plesk's.
    The last 2 days outgoing mails have suddenly stopped and watchdog informs of spamassassin stopped working.
    Even the service is restarted - or seems like - smtp server appears to be down when trying to send a mail.
    Logmail reads: connect(AF_UNIX) to spamd /tmp/spamd_full.sock failed: No such file or directory

    what I did first was "sa-learn --dump magic" followed by "sa-learn --sync -D" and restarted spamassassin from the control panel ( as "/etc/init.d/spamassassin start" says I don't have enough permissions!! ).
    Still,outgoing mail was stuck.
    Checked saslauthd but it was running, still restarted to no avail.
    stopped all the mail services as well as spamassassin from the control panel and then cd into /tmp and erased all files ".spamassassin*" .
    restarted the services and everything is working fine again.

    What can be the problem or cause? and how can we avoid this? this server has been running w/o problem for more than a year now.

    TIA,
     
Loading...