1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Outlook not working w/ SMTP Auth - lots of info given

Discussion in 'Plesk for Linux - 8.x and Older' started by mikesg, Apr 23, 2006.

  1. mikesg

    mikesg Guest

    0
     
    I have researched this subject for the better part of the day on these forums. To sum it up; I create a domain in Plesk and set up an email account. I then set up this email account on my home broadband connection. If I try to send an email from Outlook 2003 using that account and using the mail.mynewdomain.com as the SMTP server it will not send. If I try this from Mozilla or Outlook Express, it works. Though, the delivery is extremely slow. almost one minute to send a quick test email with no attachment.

    I have read in more than one place that this is probably a bug with Outlook. I have read all the proposed solutions and tried each one. From disabling and re-enabling SA or SMTP-Auth, to extending timouts and disabling read-receipts.

    Please understand I can send email just fine using another client and as such know that I need to enable "My outbound server requires authentication". This issue is with Outlook only.

    IMHO, if the fault is in Outlook, then you guys need to be the ones to provide a solution. Because MS probably won't fix this, and Outlook is so popular that you can't deny it's use with Plesk/qmail. I have never had this problem w/ Outlook until now. And after just purchasing Plesk (and raving about it to my customers) for the first time it makes me upset to have to tell my clients they can't use their own server for outgoing mail.

    This is a fresh install of Plesk 8 on minimal install of FreeBSD 6.0. I only added SpamAssassin to my purchase. So, is there a solution?
     
  2. domonus

    domonus Guest

    0
     
    Ditto!

    FC4 Fresh Plesk 8
    and a FC2 Plesk 7.5
     
  3. mikesg

    mikesg Guest

    0
     
    A quick update. I gave ssh login privs to the Plesk guys. The delay in sending email was due to the reverse lookup not seeing what it needed to see. I need to get my upstream provider to set up reverses for my IP range. But this can also be a work-around if you are unable to get reverses properly set up:
    My system being FreeBSD meant I had to edit inetd.conf instead. However they must have done something right as I can now send via SMTP auth using Outlook. I no longer believe this is an Outlook bug as Outlook 2K3 SP2, SP1 and XP SP3 all exhibit this behavior. I will ask them what their solution was and post it here, or get them to.
     
  4. mikesg

    mikesg Guest

    0
     
    Ok, the Plesk guys responded that they only removed the reverse lookup option, which actually, I did. And that's about when it started working IIRC. So reference this article and man page (same as what I posted above):

    Please reply back after doing just this and let people know if this is what solved it. So many posts out there with people doing so many things it's hard to tell if any one thing is what really solved this. Personally I think this is it though.
     
  5. phatPhrog

    phatPhrog Guest

    0
     
    SMTP outbound

    Depending on your ISP, you may or may not be allowed to send email via Outlook/Outlook Express, etc..... without making modifications to your email accounts.

    For reference purposes, I will use Outlook Express

    Go To:

    Accounts | Properties | Servers

    Check the "My server requires server authentication" Click on | Settings.

    Set your ISP username/password here if your ISP is following the trend.

    Also, some ISPs are requiring a port change:

    Accounts | Properties | Advanced | Outgoing Mail STMP (port) from 22 to 587

    If you are unsure, check your ISP FAQs or contact them.

    Seems to be a trend......makes no sense to me, but who are we, right?

    Hope this helps a bit.
     
  6. mikesg

    mikesg Guest

    0
     
    Actually no, it doesn't make sense. You're basically saying that some ISP's are fingerprinting Outlook and OE and blocking them specifically? I would need to see your sources of information for this.

    Or maybe you are saying ISP's are blocking port 25 and thus blocking your ability to run a mail server, which has nothing to do with MS mail clients. It would affect *all* mail clients. By changing the port, you get around this restriction. So qmail would need to be configured to use that same port then, but you don't mention this?
     
  7. phatPhrog

    phatPhrog Guest

    0
     
    Oops, I did say port 22.

    Yes, Port 25 is being blocked by some ISPs and must be changed to 587.

    We are in the process of running several tests, so Big Thanks for your mention of the change in qmail. We will try a reconfg to see if it resolves the issue with our email clients although that may require relaying. (not advisable)

    Not sure, maybe some mail pros could add to this.

    Just a routine Google search of

    SMTP port 587

    will net some useful and not so useful information.

    also: earthlink and sprint block outbound port 25 (in our area anyway)
     
  8. joetungsten

    joetungsten Guest

    0
     
    Hi,

    i encounterd the same probs as mike .. sending emails via outlook.

    what i've done is to solve:

    diabling reverse lookuo as explaind by faq.swsoft (link provided by mar). Now it works fine.

    Our explanation why it works now with outlook:
    during the reverselookup the smtp server (qmail) isn't responding to outlook, so outlook assumes that the connection is broken.

    I think there is a timeout in outlook for establishing the smtp connection.

    conclusion:
    We dont need reverselookup, so no problem with diabling it.

    Joe
     
  9. origin

    origin Guest

    0
     
    Took care of my problem

    I could connect to SMTP just fine but the connection would time out after a while. I could not figure out what the problem was and spent 2 days on the KnowledgeBase and Forums trying to find a fix.

    The -Rt0 addition to the smtp_psa file worked! I am having no problems with incoming or outgoing (with authentication) mail.

    Thanks.
     
  10. merlin@

    merlin@ Guest

    0
     
    I'm also seeing the long SMTP delay when sending email so plan to add -Rt0 to server_args in smtp_psa

    Before I do, I have a couple of (newbie) questions:

    1) Is there a down-side to turning off the reverse DNS look-up? - presumably the look-up was in there for a good reason so I'm wondering if something else won't work quite as well, or it will open up a security problem.

    2) Should I update smtps_psa as well?

    3) The web site typically has 600+ concurrent users - is restarting xinetd going to cause a hiccup for them?

    TIA
     
  11. DCNet_James

    DCNet_James Guest

    0
     
  12. merlin@

    merlin@ Guest

    0
     
    James,

    I understand what the problems is, and how to bypass it (turn off the rDNS).

    Assuming the rDNS lookup was originally there for a good reason, my question asks what are the side effects/risks of taking it out??
     
  13. fire692

    fire692 Guest

    0
     
    I too have this problem and am concerned about the potential problems of removing reverse DNS. Anything we should be worried about?

    Thank you

    Update: I changed file settings per the above suggested and restarted qmail. Still not working. Should I try using other ports than 25?

    I will research further and report any progress back later.
     
Loading...