• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Permission issue with new website created in Plesk

qualispace

Regular Pleskian
In one of the VPS' whenever a new website is created through Plesk, the main directory of the website is automatically assigned the permission 0710. The httpdocs and the other directories are assigned the correct permissions. As a result, the websites always show access denied error. It gets fixed when the directory is assigned correct permissions. How can we resolve this issue permanently?
 
On my test Plesk 12 server I see the same behaviour:

# stat /var/www/vhosts/ppu12-0.demo.pp.plesk.ru/
File: `/var/www/vhosts/ppu12-0.demo.pp.plesk.ru/'
Size: 4096 Blocks: 8 IO Block: 4096 directory
Device: 3a30b611h/976270865d Inode: 660213 Links: 4
Access: (0710/drwx--x---) Uid: (10000/bailee4702.ward) Gid: ( 502/ psaserv)

# stat /var/www/vhosts/ppu12-0.demo.pp.plesk.ru/httpdocs/
File: `/var/www/vhosts/ppu12-0.demo.pp.plesk.ru/httpdocs/'
Size: 4096 Blocks: 8 IO Block: 4096 directory
Device: 3a30b611h/976270865d Inode: 660214 Links: 6
Access: (0750/drwxr-x---) Uid: (10000/bailee4702.ward) Gid: ( 502/ psaserv)

Looks like this issue is caused by other reason. What is you Plesk version? 12.0 or 12.5?
 
Back
Top